On Thu, Oct 20, 2016 at 11:05:36PM +0800, Michal Privoznik wrote:
On 20.10.2016 22:27, Ján Tomko wrote:
> On Thu, Oct 20, 2016 at 10:16:05PM +0800, Michal Privoznik wrote:
>> instead of:
>>
>> virBufferAdd(buf, "arg1,");
>> virBufferAdd(buf, "arg2");
>>
>> lets have:
>>
>> virBufferAdd(buf, "arg1");
>> virBufferAdd(buf, ",arg2");
>>
>
> Why?
Because it's better. Consider we want to add conditionally arg3. With my
change, it's simple:
if (cond)
virBufferAdd(buf, ",arg3");
with current code there might be a comma hanging at EOL.
ACK with the explanation included in the commit message.
Please substitute the 'Fix' in the summary for something
that does not imply a functional change.
Jan