This series splits the sources in the 3 parts built on their own
(instead of a whole source including everything), so it is easier to
rebuild on changes.
Also, improve their file names.
Pino Toscano (6):
Rename libvirt_c_prologue.c to libvirt_c.h
Turn libvirt_c.h as proper header
Build C sources separately
Rename the generated libvirt_c.c to libvirt_generated.c
Build libvirt_generated.c with -Wmissing-prototypes
Rename libvirt_c_epilogue.c to libvirt_c_common.c
.gitignore | 2 +-
MANIFEST | 4 +-
Makefile.in | 2 +-
libvirt/Makefile.in | 22 +++----
libvirt/README | 40 ++++---------
libvirt/generator.pl | 29 ++-------
libvirt/libvirt.mli | 6 +-
libvirt/{libvirt_c_prologue.c => libvirt_c.h} | 60 +++++++++++++------
...ibvirt_c_epilogue.c => libvirt_c_common.c} | 40 +++++++------
libvirt/libvirt_c_oneoffs.c | 2 +
10 files changed, 99 insertions(+), 108 deletions(-)
rename libvirt/{libvirt_c_prologue.c => libvirt_c.h} (79%)
rename libvirt/{libvirt_c_epilogue.c => libvirt_c_common.c} (97%)
--
2.21.0