On 02/22/2012 07:51 AM, Jiri Denemark wrote:
I was also wondering if we should rather use more specific name for both
the error code and flag, such as VIR(_ERR)?_MIGRATE_UNSAFE_CACHE
(or ...UNSAFE_DISK) in the case we find other unsafe conditions...
I think that if we ever have sub-categories of unsafe operations, where
we want the user to pass varying flags to allow one but not the other
sub-category, then we could do:
VIR_ERR_MIGRATION_UNSAFE_CACHE = 1<<9,
VIR_ERR_MIGRATION_UNSAFE_DISK = 1<<10,
VIR_ERR_MIGRATION_UNSAFE =
(VIR_ERR_MIGRATION_UNSAFE_CACHE|VIR_ERR_MIGRATION_UNSAFE_DISK)
that is, make the current generic name remain generic by having it cover
multiple bits, while the specific bits control the sub-options. But for
now, I'm fine with just a single, shorter, name.
--
Eric Blake eblake(a)redhat.com +1-919-301-3266
Libvirt virtualization library
http://libvirt.org