8 Build system
--------------
M .cvsignore
M configure.in
A libvirtd.conf
M src/Makefile.am
A RENAMES
These are the changes to make it build.
libvirtd.conf is a suggested configuration file. I'm not really sure if
we should include this.
RENAMES is my collection of file renames that we might want to carry out
to make the naming scheme of things like drivers in the libvirt source
more consistent (particularly after xen-unified went it).
Rich.
--
Emerging Technologies, Red Hat
http://et.redhat.com/~rjones/
64 Baker Street, London, W1U 7DF Mobile: +44 7866 314 421
Registered Address: Red Hat UK Ltd, Amberley Place, 107-111 Peascod
Street, Windsor, Berkshire, SL4 1TE, United Kingdom.
Registered in England and Wales under Company Registration No. 3798903
Directors: Michael Cunningham (USA), Charlie Peters (USA) and David
Owens (Ireland)
# Example /etc/libvirt/libvirtd.conf file.
tls_no_verify_certificate = 1
# Suggested list of file renames.
#
# File renames don't normally go into patches because they make
# the patches much harder to read, so list them here instead.
#
# $Id$
# Clearer naming scheme after Xen-unified patch went in.
src/xen_internal.c src/xen_internal_hv.c
src/xen_internal.h src/xen_internal_hv.h
src/proxy_internal.c src/xen_internal_proxy.c
src/proxy_internal.h src/xen_internal_proxy.h
src/xend_internal.c src/xen_internal_xend.c
src/xend_internal.h src/xen_internal_xend.h
src/xm_internal.c src/xen_internal_inactive.c
src/xm_internal.h src/xen_internal_inactive.h
src/xs_internal.c src/xen_internal_xenstore.c
src/xs_internal.h src/xen_internal_xenstore.h
src/xen_unified.c src/xen_internal.c
src/xen_unified.h src/xen_internal.h
# Test driver should really be called test_internal.
src/test.c src/test_internal.c
src/test.h src/test_internal.h
# This would be better:
src/*_internal*.c src/*_driver*.c
src/*_internal*.h src/*_driver*.h
# Qemud is now the qemud + remote driver.
qemud/protocol.x qemud/qemud_protocol.x
qemud/* remote/*