On Fri, Jun 07, 2013 at 01:42:10PM +0200, Jiri Denemark wrote:
On Thu, Jun 06, 2013 at 18:11:39 +0200, Michal Privoznik wrote:
> This internal API checks, if passed address is ANYCAST address.
> ---
> src/libvirt_private.syms | 1 +
> src/util/virsocketaddr.c | 20 ++++++++++++++++++++
> src/util/virsocketaddr.h | 1 +
> tests/sockettest.c | 38 ++++++++++++++++++++++++++++++++++++++
> 4 files changed, 60 insertions(+)
>
> diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
> index b93629f..1ea7467 100644
> --- a/src/libvirt_private.syms
> +++ b/src/libvirt_private.syms
> @@ -1782,6 +1782,7 @@ virSocketAddrGetPort;
> virSocketAddrGetRange;
> virSocketAddrIsNetmask;
> virSocketAddrIsPrivate;
> +virSocketAddrIsWildcard;
I think the idea was to replace Anycast with Wildcard in tests but keep
virSocketAddrIsAny as the API name. Otherwise, ACK series.
I'm fine with using Wildcard as the name of the API too. I think it is
a little more descriptive than 'Any' too.
Daniel
--
|:
http://berrange.com -o-
http://www.flickr.com/photos/dberrange/ :|
|:
http://libvirt.org -o-
http://virt-manager.org :|
|:
http://autobuild.org -o-
http://search.cpan.org/~danberr/ :|
|:
http://entangle-photo.org -o-
http://live.gnome.org/gtk-vnc :|