Patch v1 here:
https://www.redhat.com/archives/libvir-list/2018-August/msg01413.html
Shi Lei (4):
1/4: Introduce virNetlinkNewLink
(Since v1)
- Remove callback and just use special-case to handle macvlan
in virNetlinkNewLink
- Add struct virNetlinkNewLinkData to pack some arguments of
virNetlinkNewLink
2/4: Add wrapper macros around nla_nest*/nla_put* to make code more readable
(New patch)
- Add wrapper macros according to the code written by Erik
- Apply these macros to virNetlinkNewLink and virNetDevSetVfConfig
and virNetDevVPortProfileOpSetLink
3/4: Using virNetlinkNewLink to simplify virNetDev*Create
(Since v1)
- Remove the callback for macvlan in virnetdevmacvlan.c
4/4: Remove virNetDevPutExtraHeader and replace with nlmsg_append
(New patch)
src/libvirt_private.syms | 1 +
src/util/virnetdev.c | 98 ++++++++---------------
src/util/virnetdevbridge.c | 78 ++++---------------
src/util/virnetdevmacvlan.c | 109 ++++----------------------
src/util/virnetdevvportprofile.c | 117 +++++++++-------------------
src/util/virnetlink.c | 130 +++++++++++++++++++++++++------
src/util/virnetlink.h | 65 ++++++++++++++++
7 files changed, 270 insertions(+), 328 deletions(-)
--
2.17.1