
As promised in the libvirt-qpid thread, virDomainCreateLinux() call name makes no sense (anymore), and it should be renamed, i guess since virDomainCreate() already exist and by similarity with virDomainDefineXML() the best name is virDomainCreateXML(). The associated patch rename virDomainCreateLinux to virDomainCreateXML create a small function virDomainCreateLinux calling the former, document it as deprecated. To help comprehension of the source code it's also best to rename the internal driver method in a similar way, which inflates the patch a bit but is IMHO worth it. The patch also fixes a few #elif define(__sun__) and turn them into the correct #elif defined(__sun__) cpp instructions, and changes include/libvirt/virterror.h to improve the generated HTML page about the deprected fileds in the structure, since we need to regenerate the API xml and the docs, it was a good opportunity for that small change. I removed the docs/ subdir part from the patch as it's generated and mostly unreadable, that keeps it smaller too. Daniel -- Daniel Veillard | libxml Gnome XML XSLT toolkit http://xmlsoft.org/ daniel@veillard.com | Rpmfind RPM search engine http://rpmfind.net/ http://veillard.com/ | virtualization library http://libvirt.org/