On 05/22/2014 07:48 AM, Peter Krempa wrote:
To allow using the array manipulation macros on the arrays returned
by
virStringSplit we need to know the count of the elements in the array.
Modify virStringSplit to return this value, rename it and add a helper
with the old name so that we don't need to update all the code.
---
src/libvirt_private.syms | 1 +
src/util/virstring.c | 24 ++++++++++++++++++++----
src/util/virstring.h | 6 ++++++
3 files changed, 27 insertions(+), 4 deletions(-)
Makes sense, but you should also enhance tests/virstringtest.c to cover
the new function.
--
Eric Blake eblake redhat com +1-919-301-3266
Libvirt virtualization library
http://libvirt.org