On Tue, Jul 02, 2019 at 14:28:59 +0200, Ilias Stamatis wrote:
This macro can be used by most or all of the DomainGetXXXParameters
APIs.
Signed-off-by: Ilias Stamatis <stamatis.iliass(a)gmail.com>
---
src/test/test_driver.c | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/src/test/test_driver.c b/src/test/test_driver.c
index 4b1f2724a0..29b388e2d3 100644
--- a/src/test/test_driver.c
+++ b/src/test/test_driver.c
@@ -2844,6 +2844,13 @@ static char *testDomainGetXMLDesc(virDomainPtr domain, unsigned
int flags)
return ret;
}
+
+#define TEST_SET_PARAM(index, name, type, value) \
The macro name is too generic and this patch is not undefing it. You
should do it to prevent some accidental use in other parts of the code.