On Thu, 2021-01-14 at 12:03 +0100, Erik Skultety wrote:
-.cross_build_default_job_template: &cross_build_job_definition
+.cross_build_default_job_template:
Since we're changing everything, can we drop the _template suffix
entirely and just have
.container_job:
.native_build_job:
.cirrus_build_job:
.cross_build_job:
I'm pointing this out specifically here because the cross-build job
even has a mismatch between the _template and _definition names.
armv7l-debian-10-container:
- <<: *container_optional_job_definition
+ extends: .container_job_template
variables:
NAME: debian-10-cross-armv7l
i686-debian-10-container:
- <<: *container_optional_job_definition
+ extends: .container_job_template
variables:
NAME: debian-10-cross-i686
You turned these from optional jobs to required jobs, which I assume
was not intentional.
--
Andrea Bolognani / Red Hat / Virtualization