Note: this series is to be applied on top of the
[PATCH 00/03] nodeinfo: Various fixes
series I've posted at the same time.
A bunch of improvements and cleanups that make the nodeinfo
code a bit nicer, more streamlined and less redundant, hopefully
not just to my eyes.
Andrea Bolognani (10):
nodeinfo: Introduce linuxGetCPUGlobalPath()
nodeinfo: Introduce linuxGetCPUOnlinePath()
nodeinfo: Rename linuxParseCPUmax() to linuxParseCPUCount()
nodeinfo: Add old kernel compatibility to nodeGetPresentCPUBitmap()
nodeinfo: Add out parameter to nodeGetPresentCPUBitmap()
nodeinfo: Rename nodeGetCPUBitmap() to nodeGetOnlineCPUBitmap()
nodeinfo: Phase out cpu_set_t usage
nodeinfo: Use nodeGetOnlineCPUBitmap() when parsing node
nodeinfo: Use a bitmap to keep track of node CPUs
nodeinfo: Calculate present and online CPUs only once
src/libvirt_private.syms | 2 +-
src/nodeinfo.c | 211 +++++++++++++++++++++++++++++------------------
src/nodeinfo.h | 6 +-
src/util/vircgroup.c | 4 +-
4 files changed, 139 insertions(+), 84 deletions(-)
--
2.4.3