On 06/23/2011 07:35 AM, Daniel P. Berrange wrote:
> @@ -234,6 +234,7 @@ typedef virDomainInfo *virDomainInfoPtr;
> typedef enum {
> VIR_DOMAIN_NONE = 0, /* Default behavior */
> VIR_DOMAIN_START_PAUSED = 1 << 0, /* Launch guest in paused state */
> + VIR_DOMAIN_START_AUTOKILL = 1 << 1, /* Automatically kill guest when
virConnectPtr is closed */
> } virDomainCreateFlags;
I'm thinking perhaps I should rename that to AUTODESTROY
instead, since that matches the terminology we use here.
'kill' is specific to UNIX processes, and if we want to
extend the autodestroy concept to storage pools or virtual
networks, AUTODESTROY makes more sense.
Indeed, that does sound better.
--
Eric Blake eblake(a)redhat.com +1-801-349-2682
Libvirt virtualization library
http://libvirt.org