On Wed, 2019-01-23 at 16:32 -0500, Cole Robinson wrote:
[...]
static int
-qemuDomainRNGDefValidate(const virDomainRNGDef *def)
+qemuDomainRNGDefValidate(const virDomainRNGDef *def,
+ virQEMUCapsPtr qemuCaps)
{
+ bool model_supported = false;
We usually prefer camelCase to snake_case, so I'd call this
modelSupported or even modelIsSupported.
[...]
@@ -2276,10 +2276,9 @@ qemuDomainAssignDevicePCISlots(virDomainDefPtr
def,
goto error;
}
- /* VirtIO RNG */
+ /* rng. the qemu driver only accepts virtio rng devices */
This comment looks weird, I guess the "rng. " bit slipped in.
Regardless of whether you feel like renaming the variable or not,
Reviewed-by: Andrea Bolognani <abologna(a)redhat.com>
--
Andrea Bolognani / Red Hat / Virtualization