Moving the first functions seems more important than the fact that
we are introducing a new file.
qemu: move qemuDomainDefValidateFeatures to qemu_validate
On a Thursday in 2020, Daniel Henrique Barboza wrote:
While moving validations from qemu_command to qemu_domain,
it was suggested that we should instead move them to a new
file [1] because qemu_domain is already too crowded.
This will become a part of the git history, but the cover letter will
not, so the above [1] will become a dead reference.
I'd just drop the above paragraph.
This patch introduces a new file to host such validations from
s/such/domain/
the QEMU driver. And to get things started, let's move
qemuDomainDefValidateFeatures() to this new file.
Signed-off-by: Daniel Henrique Barboza <danielhb413(a)gmail.com>
---
po/POTFILES.in | 1 +
src/qemu/Makefile.inc.am | 2 +
src/qemu/qemu_domain.c | 286 +-----------------------------------
src/qemu/qemu_validate.c | 310 +++++++++++++++++++++++++++++++++++++++
src/qemu/qemu_validate.h | 29 ++++
5 files changed, 344 insertions(+), 284 deletions(-)
create mode 100644 src/qemu/qemu_validate.c
create mode 100644 src/qemu/qemu_validate.h
Reviewed-by: Ján Tomko <jtomko(a)redhat.com>
(no need to resend unless you disagree, I'll try to merge as much as I
can today so that new patches can use the file)
Jano