
On Thu, Nov 08, 2012 at 10:30:55AM -0500, James B. Byrne wrote:
On Thu, November 8, 2012 09:24, Daniel P. Berrange wrote:
NACK to this patch. I think the current command names are good. Creating duplicates will make life worse. First, it creates divergance from the similarly named commands for networks, storage and other objects. It also means scripts written again the new commands will not work with existing libvirt.
Duplicates (aliases) will make life worse for whom? In what way? On what evidence? The present nomenclature is idiomatic to virsh and is a variance with how many people think of managing a host whether virtual or not. On the other hand, one does not customarily speak of rebooting a network or a storage array, at least not in my experience.
I actually think that shutdown & reboot are *better* names than restart and stop.
Then change start to boot and be done with it. But, the issue really is what English words are commonly associated with each other in the context we are dealing with. I submit that 'start' is not intuitively associated with 'shutdown' by the vast majority of English speakers and hardly associated with 'reboot' by any.
Consider the syntax of 'initctl' and 'service'. Initctl uses start, stop and restart. Service scripts virtually without exception use start, stop and restart, including that for libvirtd. Operators are far more likely to be familiar with this combination of terms than any other. Why force them to learn yet one more variant? What is the advantage for the users?
If you are comparing to init services, then the 'stop' verb is semanticaly equivalent to libvirt's 'destory' verb, not the shutdown verb. 'stop' does a synchronous termination of the service. Daniel -- |: http://berrange.com -o- http://www.flickr.com/photos/dberrange/ :| |: http://libvirt.org -o- http://virt-manager.org :| |: http://autobuild.org -o- http://search.cpan.org/~danberr/ :| |: http://entangle-photo.org -o- http://live.gnome.org/gtk-vnc :|