On Fri, Jun 15, 2007 at 05:57:30AM -0400, Daniel Veillard wrote:
On Thu, Jun 14, 2007 at 09:18:14PM -0400, Mark Johnson wrote:
> diff --git a/src/xml.c b/src/xml.c
> --- a/src/xml.c
> +++ b/src/xml.c
> @@ -812,12 +812,18 @@ virDomainParseXMLOSDescPV(virConnectPtr
> return (-1);
> }
> virBufferAdd(buf, "(image (linux ", 14);
> +#ifdef __linux__
> if (kernel == NULL) {
> virXMLError(conn, VIR_ERR_NO_KERNEL, NULL, 0);
> return (-1);
> } else {
> virBufferVSprintf(buf, "(kernel '%s')", (const char *)
kernel);
> }
> +#else
> + if (kernel != NULL) {
> + virBufferVSprintf(buf, "(kernel '%s')", (const char *)
kernel);
> + }
> +#endif
hum is that really minimal we can probably avoid the duplicate code no ?
Since John's change to upstream XenD for bootloaders impacts both Solaris &
Linux we need this change unconditionally on both platforms.
Dan
--
|=- Red Hat, Engineering, Emerging Technologies, Boston. +1 978 392 2496 -=|
|=- Perl modules:
http://search.cpan.org/~danberr/ -=|
|=- Projects:
http://freshmeat.net/~danielpb/ -=|
|=- GnuPG: 7D3B9505 F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 -=|