On 09/10/2012 06:08 AM, Osier Yang wrote:
* include/libvirt/libvirt.h.in: (Add macros for the param fields,
declare the APIs).
* src/driver.h: (New methods for the driver struct)
* src/libvirt.c: (Implement the public APIs)
* src/libvirt_public.syms: (Export the public symbols)
---
include/libvirt/libvirt.h.in | 63 ++++++++++++++++++++++
python/generator.py | 2 +
src/driver.h | 14 +++++
src/libvirt.c | 121 ++++++++++++++++++++++++++++++++++++++++++
src/libvirt_public.syms | 2 +
5 files changed, 202 insertions(+), 0 deletions(-)
Looks good in general, once you squash in the renames mentioned in your
followup patch, and once we settle the bikeshed question of whether to
drop 'Shared' from the API names.
--
Eric Blake eblake(a)redhat.com +1-919-301-3266
Libvirt virtualization library
http://libvirt.org