On 2/22/20 5:31 PM, Ján Tomko wrote:
The netdev_bandwidth_conf module contains
XML parsing and formatting functions operating
on types from util/virnetdevbandwidth.h
as well as helper functions using types
from domain_conf.h and network_conf.h
It does not, however, introduce any new types,
so there's no need to include its header in
other header files.
Move its inclusion in networkportdef.h to the
corresponding networkportdef.c file, where it's
used, which clears the path for networkportdef.h
inclusion in domain_conf.h.
Patch 1 is unrelated;
Patch 5 was intended to help remove the dependency
of the header file on network_conf.h (by passing int
instead of enum) and patch 6 would lessen the
dependency from domain_conf.h to virconftypes.h,
but later I realized this might not be necessary.
(Thanks, Pavel!)
Ján Tomko (8):
conf: virnwfilterbindingdef: include virxml.h
bridge: include netdev_bandwidth_conf.h
conf: virnetworkportdef: include virnetdevmacvlan
conf: rename virNetDevSupportBandwidth to virNetDevSupportsBandwidth
conf: virNetDevSupportsBandwidth: move into the C file
conf: do not pass vm object to virDomainClearNetBandwidth
conf: reduce includes in virnetworkportdef.h
conf: include virnetworkportdef.h in domain_conf.h
src/conf/domain_conf.h | 6 +-----
src/conf/netdev_bandwidth_conf.c | 35 ++++++++++++++++++++++++++------
src/conf/netdev_bandwidth_conf.h | 26 ++----------------------
src/conf/virnetworkportdef.c | 5 +++++
src/conf/virnetworkportdef.h | 3 ---
src/conf/virnwfilterbindingdef.h | 1 +
src/libvirt_private.syms | 1 +
src/lxc/lxc_driver.c | 4 ++--
src/lxc/lxc_process.c | 2 +-
src/network/bridge_driver.c | 2 ++
src/qemu/qemu_command.c | 2 +-
src/qemu/qemu_driver.c | 4 ++--
src/qemu/qemu_hotplug.c | 4 ++--
src/qemu/qemu_process.c | 2 +-
14 files changed, 50 insertions(+), 47 deletions(-)
Reviewed-by: Michal Privoznik <mprivozn(a)redhat.com>
Michal