Garry Dolley wrote:
Hi Jim,
Thanks for this suggestion, it worked like a charm!
Now, while this is still a "hacky" way to solve this problem, would
anyone be interested in seeing a patch that would either:
1) Allow one to append arbitrary command line arguments to the
emulator, like:
...
<emulator>/usr/bin/kvm<emulator>
<emulator_args>-no-kvm-irqchip</emulator_args>
It's a feature request that's come up many times. Personally, I don't think
it
would be such a bad idea, but I know it's been rejected in the past, so maybe
others can chime in with their reasoning.
...
I don't like the name "emulator_args" much either, but just as an
example.
2) Have an option in the XML file specifically for
'-no-kvm-irqchip'; I'm not sure where it would go. Maybe under
"<features>", yet it isn't really a feature, more like lack of a
feature ;)
This one is probably worse off in terms of a feature request. The problem is
that this is very qemu-specific, and the libvirt XML tries to stay pretty
generic across hypervisor versions. Worse, qemu options come and go over time,
so a couple of years from now, that option may not even exist anymore. But
since the XML is part of the libvirt API, we would have to continually support
it in libvirt forever.
Suggestions welcome.
I've been waiting to find some itch to scratch where I can
contribute to libvirt code directly (instead of just doc patches),
so this seems to fit the bill.
There is this page on the libvirt wiki:
http://wiki.libvirt.org/page/Todo, but
I'll warn you that it is very out-of-date. If you see something on there that
tickles your fancy, make sure to mail the list first asking if it's already done
or in progress.
--
Chris Lalancette