On Mon, 4 Oct 2021, Laine Stump wrote:
On 10/4/21 1:26 PM, Ani Sinha wrote:
> The capability name piix4-acpi-root-hotplug-en is not conventional and
> appreared to be confusing to some. "en" suffix is also incorrect as the
> capability in qemu is used to both enable and disable hotplug on the pci
> root
> bus on the i440fx. Hence, rename it to piix4.acpi-root-pci-hotplug so that
> it
> is clearer, less confusing and more accurate.
>
> Signed-off-by: Ani Sinha <ani(a)anisinha.ca>
> ---
> src/qemu/qemu_capabilities.c | 2 +-
> tests/qemucapabilitiesdata/caps_5.2.0.x86_64.xml | 2 +-
> tests/qemucapabilitiesdata/caps_6.0.0.x86_64.xml | 2 +-
> tests/qemucapabilitiesdata/caps_6.1.0.x86_64.xml | 2 +-
> 4 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c
> index 9d0c96a20c..d7b79ef7c0 100644
> --- a/src/qemu/qemu_capabilities.c
> +++ b/src/qemu/qemu_capabilities.c
> @@ -641,7 +641,7 @@ VIR_ENUM_IMPL(virQEMUCaps,
> "virtio-blk.queue-size", /*
QEMU_CAPS_VIRTIO_BLK_QUEUE_SIZE
> */
> /* 410 */
> - "piix4-acpi-root-hotplug-en", /*
> QEMU_CAPS_PIIX_ACPI_ROOT_PCI_HOTPLUG */
> + "piix4.acpi-root-pci-hotplug", /*
> QEMU_CAPS_PIIX_ACPI_ROOT_PCI_HOTPLUG */
Since the enum matched the capability name exactly except that one is "piix4"
and the other is "PIIX", I changed the enum to match this new name before
pushing.
Reviewed-by: Laine Stump <laine(a)redhat.com>
Will be pushed in a few minutes as soon as gitlab CI finishes running on my
review branch.
Alright. I have made equivalent changes for pci-hotplug-bridge patchset as
well. Please take a look. Hopefully we can wrap that patchset within this
week before we all start forgetting the context.
> );
> diff --git a/tests/qemucapabilitiesdata/caps_5.2.0.x86_64.xml
> b/tests/qemucapabilitiesdata/caps_5.2.0.x86_64.xml
> index 1e5833a9f0..834fb86636 100644
> --- a/tests/qemucapabilitiesdata/caps_5.2.0.x86_64.xml
> +++ b/tests/qemucapabilitiesdata/caps_5.2.0.x86_64.xml
> @@ -230,7 +230,7 @@
> <flag name='input-linux'/>
> <flag name='query-display-options'/>
> <flag name='virtio-blk.queue-size'/>
> - <flag name='piix4-acpi-root-hotplug-en'/>
> + <flag name='piix4.acpi-root-pci-hotplug'/>
> <version>5002000</version>
> <kvmVersion>0</kvmVersion>
> <microcodeVersion>43100243</microcodeVersion>
> diff --git a/tests/qemucapabilitiesdata/caps_6.0.0.x86_64.xml
> b/tests/qemucapabilitiesdata/caps_6.0.0.x86_64.xml
> index b54dd8a22e..e9d1a26400 100644
> --- a/tests/qemucapabilitiesdata/caps_6.0.0.x86_64.xml
> +++ b/tests/qemucapabilitiesdata/caps_6.0.0.x86_64.xml
> @@ -238,7 +238,7 @@
> <flag name='query-display-options'/>
> <flag name='set-action'/>
> <flag name='virtio-blk.queue-size'/>
> - <flag name='piix4-acpi-root-hotplug-en'/>
> + <flag name='piix4.acpi-root-pci-hotplug'/>
> <version>6000000</version>
> <kvmVersion>0</kvmVersion>
> <microcodeVersion>43100242</microcodeVersion>
> diff --git a/tests/qemucapabilitiesdata/caps_6.1.0.x86_64.xml
> b/tests/qemucapabilitiesdata/caps_6.1.0.x86_64.xml
> index 0ad493191d..971d55e0cc 100644
> --- a/tests/qemucapabilitiesdata/caps_6.1.0.x86_64.xml
> +++ b/tests/qemucapabilitiesdata/caps_6.1.0.x86_64.xml
> @@ -240,7 +240,7 @@
> <flag name='query-display-options'/>
> <flag name='set-action'/>
> <flag name='virtio-blk.queue-size'/>
> - <flag name='piix4-acpi-root-hotplug-en'/>
> + <flag name='piix4.acpi-root-pci-hotplug'/>
> <version>6001000</version>
> <kvmVersion>0</kvmVersion>
> <microcodeVersion>43100243</microcodeVersion>
>