On Wed, 2018-04-25 at 13:43 +0200, Ján Tomko wrote:
On Wed, Apr 25, 2018 at 12:20:18PM +0200, Katerina Koukiou wrote:
> Signed-off-by: Katerina Koukiou <kkoukiou(a)redhat.com>
> ---
> data/org.libvirt.Domain.xml | 7 +++++++
> src/domain.c | 40
> ++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 47 insertions(+)
>
> diff --git a/data/org.libvirt.Domain.xml
> b/data/org.libvirt.Domain.xml
> index 2d8f6fe..6f80cc7 100644
> --- a/data/org.libvirt.Domain.xml
> +++ b/data/org.libvirt.Domain.xml
> @@ -171,6 +171,13 @@
> <arg name="flags" type="u"
direction="in"/>
> <arg name="BlkioParameters" type="a{sv}"
direction="out"/>
> </method>
> + <method name="GetBlockIoTune">
s/Io/IO/
it's capitalized in every API implemented so far'
I follow the convention that I keep the method name as the original API
name, apart from when there is the `Flags` suffix. Would you mind if we
keep using this approach?
Katerina
> + <annotation name="org.gtk.GDBus.DocString"
> + value="See
https://libvirt.org/html/libvirt-libvirt-domain
> .html#virDomainGetBlockIoTune"/>;
> + <arg name="disk" type="s"
direction="in"/>
> + <arg name="flags" type="u"
direction="in"/>
> + <arg name="blockIoTune" type="a{sv}"
direction="out"/>
here too
> + </method>
> <method name="GetControlInfo">
> <annotation name="org.gtk.GDBus.DocString"
> value="See
https://libvirt.org/html/libvirt-libvirt-domain.
> html#virDomainGetControlInfo"/>;
Reviewed-by: Ján Tomko <jtomko(a)redhat.com>
Jano