On Thu, Oct 19, 2017 at 08:08:34AM -0400, John Ferlan wrote:
On 10/17/2017 11:04 AM, Ján Tomko wrote:
> Let it be reused in qemu_domain_address.
Alternatively you could have added "#include qemu_command.h" to
qemu_domain_address.c, right?
The function does not deal directly with the command line and
including qemu_command.h would feel wrong.
IDC about moving, but if you do....
[...]
> diff --git a/src/qemu/qemu_domain.h b/src/qemu/qemu_domain.h
> index 5201c6a0a..6abefc929 100644
> --- a/src/qemu/qemu_domain.h
> +++ b/src/qemu/qemu_domain.h
> @@ -978,4 +978,9 @@ qemuDomainFixupCPUs(virDomainObjPtr vm,
> char *
> qemuDomainGetMachineName(virDomainObjPtr vm);
>
> +bool qemuCheckCCWS390AddressSupport(const virDomainDef *def,
> + virDomainDeviceInfo info,
> + virQEMUCapsPtr qemuCaps,
> + const char *devicename);
More recently I've been encouraged by some reviewers to use:
bool
qemuDomainCheck...();
type format to follow the .c file format when adding functions.
I purposefully formatted it this way to match most of the prototypes
in the file.
Jan
John
> +
> #endif /* __QEMU_DOMAIN_H__ */
>