On 07/11/2014 06:35 AM, John Ferlan wrote:
Create a separate typedef for the hostdev union data describing PCI.
Then adjust the code to use the new pointer
Signed-off-by: John Ferlan <jferlan(a)redhat.com>
---
Starting to get the rebase conflicts here; so yes, reposting the rest of
the series would help review.
src/conf/domain_audit.c | 9 ++++----
src/conf/domain_conf.c | 25 ++++++++++++---------
src/conf/domain_conf.h | 12 ++++++----
src/libxl/libxl_conf.c | 9 ++++----
src/libxl/libxl_domain.c | 5 +++--
src/libxl/libxl_driver.c | 34 ++++++++++++++---------------
src/qemu/qemu_cgroup.c | 24 ++++++++++----------
src/qemu/qemu_command.c | 47 ++++++++++++++++++----------------------
src/qemu/qemu_hotplug.c | 11 +++++-----
src/security/security_apparmor.c | 10 ++++-----
src/security/security_dac.c | 20 +++++++----------
src/security/security_selinux.c | 20 +++++++----------
src/util/virhostdev.c | 34 ++++++++++++-----------------
13 files changed, 125 insertions(+), 135 deletions(-)
Based solely on visual review for this one:
@@ -10123,10 +10124,13 @@ static int
virDomainHostdevMatchSubsysPCI(virDomainHostdevDefPtr a,
virDomainHostdevDefPtr b)
{
- if (a->source.subsys.u.pci.addr.domain == b->source.subsys.u.pci.addr.domain
&&
- a->source.subsys.u.pci.addr.bus == b->source.subsys.u.pci.addr.bus
&&
- a->source.subsys.u.pci.addr.slot == b->source.subsys.u.pci.addr.slot
&&
- a->source.subsys.u.pci.addr.function ==
b->source.subsys.u.pci.addr.function)
+ virDomainHostdevSubsysPCIPtr apcisrc = &a->source.subsys.u.pci;
+ virDomainHostdevSubsysPCIPtr bpcisrc = &b->source.subsys.u.pci;
Similar to 1/8, naming this 'a_pcisrc' or even 'first' might be easier
to read.
ACK, if the rebase is simple.
--
Eric Blake eblake redhat com +1-919-301-3266
Libvirt virtualization library
http://libvirt.org