On Wed, Jun 03, 2015 at 13:06:57 -0400, John Ferlan wrote:
Commit id '887dd362' added support for a netfs pool format
type 'cifs'
and 'gluster' in order to add rng support for Samba and glusterfs netfs
pools. Originally, the CIFS type support was added as part of commit
id '61fb6979'. Eventually commit id 'b325be12' fixed the gluster rng
definition to match expectations.
As it turns out the CIFS rng needed a similar change since the directory
path is not an absDirPath, rather just a dirPath will be required.
Signed-off-by: John Ferlan <jferlan(a)redhat.com>
---
docs/schemas/storagepool.rng | 24 +++++++++++++++++++++++-
tests/storagepoolxml2xmlin/pool-netfs-cifs.xml | 12 ++++++++++++
tests/storagepoolxml2xmlout/pool-netfs-cifs.xml | 15 +++++++++++++++
tests/storagepoolxml2xmltest.c | 1 +
4 files changed, 51 insertions(+), 1 deletion(-)
create mode 100644 tests/storagepoolxml2xmlin/pool-netfs-cifs.xml
create mode 100644 tests/storagepoolxml2xmlout/pool-netfs-cifs.xml
diff --git a/docs/schemas/storagepool.rng b/docs/schemas/storagepool.rng
index db6ff49..d6bf772 100644
--- a/docs/schemas/storagepool.rng
+++ b/docs/schemas/storagepool.rng
@@ -314,6 +314,15 @@
</element>
</define>
+ <define name='sourceinfonetfscifs'>
This is equivalent to the gluster one. How about renaming the gluster
one to a more generic name ... and
+ <element name='dir'>
+ <attribute name='path'>
+ <ref name='dirPath'/>
+ </attribute>
+ <empty/>
+ </element>
+ </define>
+
<define name='sourceinfonetfsgluster'>
<element name='dir'>
<attribute name='path'>
@@ -400,7 +409,6 @@
<choice>
<value>auto</value>
<value>nfs</value>
- <value>cifs</value>
</choice>
</attribute>
</element>
@@ -488,6 +496,20 @@
<group>
<interleave>
<ref name='sourceinfohost'/>
+ <ref name='sourceinfonetfscifs'/>
+ <element name='format'>
+ <attribute name='type'>
+ <value>cifs</value>
since the whole block is identical you could just add
<choice>
<value>cifs</value>
<value>glusterfs</value>
</choice>
here to avoid duplicating the whole section.
+ </attribute>
+ </element>
+ <optional>
+ <ref name='sourceinfovendor'/>
+ </optional>
+ </interleave>
+ </group>
+ <group>
+ <interleave>
+ <ref name='sourceinfohost'/>
<ref name='sourceinfonetfsgluster'/>
<element name='format'>
<attribute name='type'>
diff --git a/tests/storagepoolxml2xmlin/pool-netfs-cifs.xml
b/tests/storagepoolxml2xmlin/pool-netfs-cifs.xml
The test section looks good to me. ACK if you avoid the duplication.
Peter