V1:
https://www.redhat.com/archives/libvir-list/2019-March/msg01455.html
I pushed patches 01-12, since they were acked, and pushing them leaves
the code in no worse state than it was before (all tests still pass).
There are 4 new patches in V2, created as a result of Peter asking for
patches to be split, or for further refactoring.
Still to be done: Peter pointed out that qemuDomainUpdateDeviceLlist()
really shouldn't be called until after qemu has sent the
DEVICE_DELETED event. That is on my list of followups, but the patches
here are still a valid improvement even without that (After his
comment, I noticed that we are also calling virDomainSaveStatus too
soon - it also shouldn't be called until after DEVICE_DELETED).
Laine Stump (14):
qemu_hotplug: move qemuDomainDetachDeviceLive() to qemu_hotplug.c
qemu_hotplug: remove extra function in middle of DetachController call
chain
qemu_hotplug: pull qemuDomainUpdateDeviceList out of
qemuDomainDetachDeviceLive
test: replace calls to individual detach functions with one call to
main detach
qemu_hotplug: make Detach functions called only from qemu_hotplug.c
static
qemu_hotplug: rename dev to match in qemuDomainDetachDeviceLive
qemu_hotplug: separate Chr|Lease from other devices in DetachDevice
switch
qemu_hotplug: standardize the names/args/calling of
qemuDomainDetach*()
qemu_hotplug: rename Chr and Lease Detach functions
qemu_hotplug: new function qemuDomainRemoveAuditDevice()
qemu_hotplug: audit *all* auditable device types in
qemuDomainRemoveAuditDevice
qemu_hotplug: consolidate all common detach code in
qemuDomainDetachDeviceLive
qemu_hotplug: delay sending DEVICE_REMOVED event until after *all*
teardown
qemu_hotplug: don't shutdown net device until the guest has released
it
src/qemu/qemu_driver.c | 109 +----
src/qemu/qemu_hotplug.c | 919 +++++++++++++++++++---------------------
src/qemu/qemu_hotplug.h | 56 +--
tests/qemuhotplugtest.c | 8 +-
4 files changed, 465 insertions(+), 627 deletions(-)
--
2.20.1