There are two main reasons behind this patchset:
- we are getting very close to 64 flags which is the maximum we can use with
unsigned long long
- by using LL constants in enum we already violates C99 constraint that enum
values have to fit into int
This is a very conflict-prone patchset so I'd like to get some feedback on the
ideas and naming used so that this could possible be among the first patches
pushed after 0.8.8 release.
Patches 2/6 and 4/6 are fully and 3/6 mostly mechanical. 5/6 and 6/6 need to be
squashed into a single patch but are provided separately for easier review.
Jiri Denemark (6):
util: Add API for converting virBitmap into printable string
qemu: Rename QEMUD_CMD_FLAG_* to QEMU_CAPS_*
qemu: Use helper functions for handling cmd line capabilities
qemu: Rename qemud\?CmdFlags to qemuCaps
qemu: Switch over command line capabilities to virBitmap
tests: Use virBitmap for qemu command line caps
src/libvirt_private.syms | 1 +
src/qemu/qemu_capabilities.c | 238 +++++++++-----
src/qemu/qemu_capabilities.h | 150 +++++----
src/qemu/qemu_command.c | 384 +++++++++++-----------
src/qemu/qemu_command.h | 30 +-
src/qemu/qemu_driver.c | 106 ++++---
src/qemu/qemu_hotplug.c | 162 +++++-----
src/qemu/qemu_hotplug.h | 32 +-
src/util/bitmap.c | 32 ++-
src/util/bitmap.h | 3 +
tests/qemuargv2xmltest.c | 2 +-
tests/qemuhelptest.c | 745 +++++++++++++++++++++---------------------
tests/qemuxml2argvtest.c | 470 +++++++++++++-------------
13 files changed, 1249 insertions(+), 1106 deletions(-)
--
1.7.4