Trivial fix to improve readability by combining these into a compound
conditional.
Signed-off-by: Jonathon Jongsma <jjongsma(a)redhat.com>
---
src/qemu/qemu_monitor_json.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/qemu/qemu_monitor_json.c b/src/qemu/qemu_monitor_json.c
index 2491cbf9b8..8d3b6c98e3 100644
--- a/src/qemu/qemu_monitor_json.c
+++ b/src/qemu/qemu_monitor_json.c
@@ -4020,9 +4020,9 @@ int qemuMonitorJSONAddFileHandleToSet(qemuMonitorPtr mon,
if (virJSONValueObjectCreate(&args, "S:opaque", opaque, NULL) < 0)
return -1;
- if (fdset >= 0)
- if (virJSONValueObjectAdd(args, "j:fdset-id", fdset, NULL) < 0)
- return -1;
+ if (fdset >= 0 &&
+ virJSONValueObjectAdd(args, "j:fdset-id", fdset, NULL) < 0)
+ return -1;
if (!(cmd = qemuMonitorJSONMakeCommandInternal("add-fd",
g_steal_pointer(&args))))
--
2.26.2