This is probably too invasive for inclusion in 0.9.1.
Eric Blake (3):
maint: rename virBufferVSprintf to virBufferAsprintf
buf: add virBufferVasprintf
virsh: use new method for easier log to file
ChangeLog-old | 2 +-
HACKING | 2 +-
bootstrap.conf | 1 +
docs/api_extension/0008-support-new-xml.patch | 46 ++--
...improve-vcpu-support-in-qemu-command-line.patch | 8 +-
...-improve-vcpu-support-in-xen-command-line.patch | 12 +-
docs/hacking.html.in | 2 +-
docs/news.html.in | 4 +-
src/conf/capabilities.c | 48 ++--
src/conf/cpu_conf.c | 24 +-
src/conf/domain_conf.c | 294 ++++++++++----------
src/conf/interface_conf.c | 60 ++--
src/conf/network_conf.c | 26 +-
src/conf/node_device_conf.c | 62 ++--
src/conf/nwfilter_conf.c | 34 ++--
src/conf/nwfilter_params.c | 2 +-
src/conf/secret_conf.c | 4 +-
src/conf/storage_conf.c | 70 +++---
src/conf/storage_encryption_conf.c | 6 +-
src/cpu/cpu_map.c | 2 +-
src/esx/esx_driver.c | 4 +-
src/esx/esx_vi.c | 2 +-
src/esx/esx_vi_types.c | 6 +-
src/libvirt_private.syms | 3 +-
src/network/bridge_driver.c | 4 +-
src/node_device/node_device_udev.c | 4 +-
src/nwfilter/nwfilter_ebiptables_driver.c | 206 +++++++-------
src/nwfilter/nwfilter_learnipaddr.c | 4 +-
src/openvz/openvz_driver.c | 18 +-
src/phyp/phyp_driver.c | 248 ++++++++--------
src/qemu/qemu_command.c | 256 +++++++++---------
src/qemu/qemu_domain.c | 6 +-
src/qemu/qemu_monitor.c | 4 +-
src/security/virt-aa-helper.c | 12 +-
src/uml/uml_conf.c | 10 +-
src/util/bitmap.c | 2 +-
src/util/buf.c | 51 +++--
src/util/buf.h | 8 +-
src/util/conf.c | 10 +-
src/util/logging.c | 8 +-
src/util/sexpr.c | 2 +-
src/util/sysinfo.c | 12 +-
src/vmx/vmx.c | 138 +++++-----
src/xen/xend_internal.c | 2 +-
src/xen/xm_internal.c | 2 +-
src/xenapi/xenapi_utils.c | 2 +-
src/xenxs/xen_sxpr.c | 60 ++--
src/xenxs/xen_xm.c | 40 ++--
tests/cputest.c | 6 +-
tests/virbuftest.c | 2 +-
tools/virsh.c | 120 +++++----
51 files changed, 994 insertions(+), 967 deletions(-)
--
1.7.4.4