On 03/14/2013 10:47 AM, Daniel P. Berrange wrote:
On Thu, Mar 14, 2013 at 10:44:32AM -0400, Stefan Berger wrote:
> On 03/14/2013 10:20 AM, Daniel P. Berrange wrote:
> Hm, this surprises me since this would put JSON specific code into
> the monitor APIs (qemu_monitor.c) while qemu_monitor.c typically only
> serves as a dispatcher for either text monitor or json monitor.
No, you mis-understand me - I mean move the code into these 2 functions:
That's also what I had at the beginning. It was obviously much
duplicated code that looked like as if it could be separated out.
Stefan
+int qemuMonitorJSONGetTPMModels(qemuMonitorPtr mon,
+ char ***tpmmodels)
+{
+ return qemuMonitorJSONGetStringArray(mon, "query-tpm-models", tpmmodels);
+}
+
+
+int qemuMonitorJSONGetTPMTypes(qemuMonitorPtr mon,
+ char ***tpmtypes)
+{
+ return qemuMonitorJSONGetStringArray(mon, "query-tpm-types", tpmtypes);
+}
Daniel