This label is used in both successful and error paths. Therefore
it should be named 'cleanup' and not 'err'.
Signed-off-by: Michal Privoznik <mprivozn(a)redhat.com>
---
src/security/security_selinux.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/security/security_selinux.c b/src/security/security_selinux.c
index 288f3628f7..35f18e1738 100644
--- a/src/security/security_selinux.c
+++ b/src/security/security_selinux.c
@@ -1306,13 +1306,13 @@ virSecuritySELinuxRestoreFileLabel(virSecurityManagerPtr mgr,
if (virFileResolveLink(path, &newpath) < 0) {
VIR_WARN("cannot resolve symlink %s: %s", path,
virStrerror(errno, ebuf, sizeof(ebuf)));
- goto err;
+ goto cleanup;
}
if (stat(newpath, &buf) != 0) {
VIR_WARN("cannot stat %s: %s", newpath,
virStrerror(errno, ebuf, sizeof(ebuf)));
- goto err;
+ goto cleanup;
}
if (getContext(mgr, newpath, buf.st_mode, &fcon) < 0) {
@@ -1325,7 +1325,7 @@ virSecuritySELinuxRestoreFileLabel(virSecurityManagerPtr mgr,
rc = virSecuritySELinuxSetFilecon(mgr, newpath, fcon);
}
- err:
+ cleanup:
freecon(fcon);
VIR_FREE(newpath);
return rc;
--
2.16.4