On 01/25/2018 10:23 AM, Erik Skultety wrote:
We currently have 2 methods that do the capability matching. This
should
be condensed to a single function and all the derivates should just call
into that using a proper type conversion.
Signed-off-by: Erik Skultety <eskultet(a)redhat.com>
---
src/conf/virnodedeviceobj.c | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/src/conf/virnodedeviceobj.c b/src/conf/virnodedeviceobj.c
index c4e3a40d3..a4d38b3a1 100644
--- a/src/conf/virnodedeviceobj.c
+++ b/src/conf/virnodedeviceobj.c
@@ -53,6 +53,8 @@ static virClassPtr virNodeDeviceObjClass;
static virClassPtr virNodeDeviceObjListClass;
static void virNodeDeviceObjDispose(void *opaque);
static void virNodeDeviceObjListDispose(void *opaque);
+static bool virNodeDeviceObjHasCapStr(const virNodeDeviceObj *obj,
+ const char *cap);
I'm failing to see why this needed. ACK to the rest though.
Michal