On 23/03/16 17:56, Peter Xu wrote:
On Wed, Mar 23, 2016 at 03:28:28PM +0300, Sergey Fedorov wrote:
> On 23/03/16 08:32, Peter Xu wrote:
>> diff --git a/include/sysemu/kvm.h b/include/sysemu/kvm.h
>> index 6695fa7..8738fa1 100644
>> --- a/include/sysemu/kvm.h
>> +++ b/include/sysemu/kvm.h
>> @@ -306,6 +306,15 @@ void kvm_device_access(int fd, int group, uint64_t attr,
>> */
>> int kvm_create_device(KVMState *s, uint64_t type, bool test);
>>
>> +/**
>> + * kvm_support_device - probe whether KVM support specific device
>> + *
>> + * @vmfd: The fd handler for VM
>> + * @type: type of device
>> + *
>> + * @return: true if supported, otherwise false.
>> + */
>> +bool kvm_support_device(int vmfd, uint64_t type);
> Why don't name the function like 'kvm_device_supported' to better express
its predicative nature?
Because I am trying to follow existing naming style, like:
"kvm_create_device" (please see above).
Yes, but kvm_create_device() returns a file descriptor whereas this
function is predicative. Personally, I like the convention described in
chapter 16 of Linux kernel coding style [1]:
If the name of a function is an action or an imperative command,
the function should return an error-code integer. If the name
is a predicate, the function should return a "succeeded" boolean.
[1]
https://www.kernel.org/doc/Documentation/CodingStyle
Kind regards,
Sergey