Fallout from review of v3 of the IV Secrets:
http://www.redhat.com/archives/libvir-list/2016-May/msg00444.html
Add a new buffer escape API to handle printing a sized buffer
Alter the existing fetch, store, and printing of the secret to
be a "uint8_t *" rather than "(unsigned) char *".
Change the name of SecretIV to SecretAES
Figured I'd work through the getting the naming right first...
John Ferlan (3):
util: Introduce virBufferEscapeSizedBuf
secret: Alter virSecretGetSecretString
qemu: Change from SecretIV or _IV to SecretAES or _AES
src/libvirt_private.syms | 1 +
src/libxl/libxl_conf.c | 18 +++++++++-------
src/qemu/qemu_command.c | 11 +++++-----
src/qemu/qemu_domain.c | 11 +++++-----
src/qemu/qemu_domain.h | 17 ++++++++-------
src/secret/secret_util.c | 19 +++++++++++++----
src/secret/secret_util.h | 13 ++++++------
src/util/virbuffer.c | 54 ++++++++++++++++++++++++++++++++++++++++++++++++
src/util/virbuffer.h | 3 +++
9 files changed, 112 insertions(+), 35 deletions(-)
--
2.5.5