This patchset intend to add cpuset support for LXC.
in order to don't create too many redundant codes,
this patchset also rename some functions.
Gao feng (4):
rename qemuGetNumadAdvice to virDomainGetNumadAdvice
LXC: allow uses advisory nodeset from querying numad
remove the redundant codes
LXC: add cpuset support for lxc
src/conf/domain_conf.c | 144 ++++++++++++++++++++++++++++++++++++++++++
src/conf/domain_conf.h | 4 ++
src/libvirt_private.syms | 3 +-
src/lxc/lxc_cgroup.c | 58 ++++++++++++++++-
src/lxc/lxc_cgroup.h | 2 +-
src/lxc/lxc_controller.c | 117 +++++++++--------------------------
src/qemu/qemu_process.c | 158 ++---------------------------------------------
7 files changed, 242 insertions(+), 244 deletions(-)
--
1.7.11.7