Commit a03cbfe0fb introduced a syntax-check failure: patch
1/4 prepares for 2/4, where the failure is actually fixed.
Patches 3/4 and 4/4 improve the naming consistency for mock
libraries by shuffling files around a bit.
Cheers.
Andrea Bolognani (4):
tests: Split off the mock part of the port allocator test
tests: Allow use of close() in mock libraries
tests: Don't use "lib" prefix for mock libraries
tests: Rename virmockdbus -> virdbusmock for consistency
cfg.mk | 2 +-
tests/Makefile.am | 26 ++++----
tests/{virmockdbus.c => virdbusmock.c} | 2 +-
tests/virfirewalltest.c | 2 +-
tests/virpolkittest.c | 2 +-
tests/virportallocatormock.c | 108 +++++++++++++++++++++++++++++++
tests/virportallocatortest.c | 112 +++------------------------------
tests/virsystemdtest.c | 2 +-
8 files changed, 134 insertions(+), 122 deletions(-)
rename tests/{virmockdbus.c => virdbusmock.c} (97%)
create mode 100644 tests/virportallocatormock.c
--
2.5.0