On 07/13/2011 04:19 AM, Osier Yang wrote:
1. Fix typos caused by the renaming
2. It should substitute "remote/remote_protocol.h" to
"remote_protocol.h".
---
src/rpc/gendispatch.pl | 6 +++---
src/rpc/genprotocol.pl | 2 +-
2 files changed, 4 insertions(+), 4 deletions(-)
ACK.
+++ b/src/rpc/genprotocol.pl
@@ -59,7 +59,7 @@ while (<RPCGEN>) {
s/xdr_u_quad_t/xdr_uint64_t/g;
s/xdr_quad_t/xdr_int64_t/g;
s/(?<!IXDR_GET_INT32 )IXDR_GET_LONG/IXDR_GET_INT32/g;
- s,#include "\./remote/remote_protocol\.h",#include
"remote_protocol.h",;
+ s,#include "remote/remote_protocol\.h",#include
"remote_protocol.h",;
I wonder if we could even go one step further in using:
s,#include ".*remote/remote_protocol\.h",#include
"remote_protocol.h",;
but as written, this was okay, and things compiled fine both before and
after this change.
--
Eric Blake eblake(a)redhat.com +1-801-349-2682
Libvirt virtualization library
http://libvirt.org