sorry for late reply.
在 2013-02-05二的 16:56 +0000,Daniel P. Berrange写道:
On Tue, Feb 05, 2013 at 05:53:30PM +0100, Ján Tomko wrote:
> On 01/30/13 03:30, liguang wrote:
> > @@ -4493,6 +4494,8 @@ virDomainControllerDefParseXML(xmlNodePtr node,
> > goto error;
> >
> > switch (def->type) {
> > + case VIR_DOMAIN_CONTROLLER_TYPE_PCIBRIDGE:
> > + break;
> > case VIR_DOMAIN_CONTROLLER_TYPE_VIRTIO_SERIAL: {
> > char *ports = virXMLPropString(node, "ports");
> > if (ports) {
>
> This hunk doesn't do anything and can be dropped.
>
> > diff --git a/src/conf/domain_conf.h b/src/conf/domain_conf.h
> > index 9a9e0b1..a93562d 100644
> > --- a/src/conf/domain_conf.h
> > +++ b/src/conf/domain_conf.h
> > @@ -661,6 +661,7 @@ enum virDomainControllerType {
> > VIR_DOMAIN_CONTROLLER_TYPE_VIRTIO_SERIAL,
> > VIR_DOMAIN_CONTROLLER_TYPE_CCID,
> > VIR_DOMAIN_CONTROLLER_TYPE_USB,
> > + VIR_DOMAIN_CONTROLLER_TYPE_PCIBRIDGE,
> >
> > VIR_DOMAIN_CONTROLLER_TYPE_LAST
> > };
> >
> VIR_DOMAIN_CONTROLLER_TYPE_PCI_BRIDGE would be nicer. Or maybe just
> VIR_DOMAIN_CONTROLLER_TYPE_PCI would do.
FYI, PCI_BRIDGE is better, because in the future we'll have the option
of multiple PCI roots, implying a CONTROLLER_TYPE_PCI_ROOT or something
like that
I think what you called "multiple PCI roots" is pci root bridge, isn't
it? so, do we need a new controller name?
Daniel