On Sun, Apr 21, 2024 at 10:53:09PM -0400, Laine Stump wrote:
These functions are only ever used by the network driver, and are so
specific to the network driver's usage of iptables that they likely
won't ever be used elsewhere. The files are renamed to
network_iptables.[ch] to be more in line with driver-specific file
naming conventions.
Signed-off-by: Laine Stump <laine(a)redhat.com>
---
po/POTFILES | 2 +-
src/libvirt_private.syms | 31 -------------------
src/network/bridge_driver_linux.c | 2 +-
src/network/meson.build | 1 +
.../network_iptables.c} | 7 +++--
.../network_iptables.h} | 2 +-
src/util/meson.build | 1 -
7 files changed, 8 insertions(+), 38 deletions(-)
rename src/{util/viriptables.c => network/network_iptables.c} (99%)
rename src/{util/viriptables.h => network/network_iptables.h} (99%)
Reviewed-by: Daniel P. Berrangé <berrange(a)redhat.com>
with one question below...
diff --git a/src/util/viriptables.c b/src/network/network_iptables.c
similarity index 99%
rename from src/util/viriptables.c
rename to src/network/network_iptables.c
index 018021bc1b..bf6e3065f5 100644
--- a/src/util/viriptables.c
+++ b/src/network/network_iptables.c
@@ -1,5 +1,5 @@
/*
- * viriptables.c: helper APIs for managing iptables
+ * network_iptables.c: helper APIs for managing iptables in network driver
*
* Copyright (C) 2007-2014 Red Hat, Inc.
*
@@ -27,13 +27,14 @@
#include <sys/stat.h>
#include "internal.h"
-#include "viriptables.h"
#include "virfirewalld.h"
#include "virerror.h"
#include "virlog.h"
#include "virhash.h"
+#include "virenum.h"
Presume this virenum.h addition is an accident, that should be in a
later commit ?
+#include "network_iptables.h"
-VIR_LOG_INIT("util.iptables");
+VIR_LOG_INIT("network.iptables");
#define VIR_FROM_THIS VIR_FROM_NONE
With regards,
Daniel
--
|:
https://berrange.com -o-
https://www.flickr.com/photos/dberrange :|
|:
https://libvirt.org -o-
https://fstop138.berrange.com :|
|:
https://entangle-photo.org -o-
https://www.instagram.com/dberrange :|