On Sat, Jul 01, 2017 at 10:42:56 -0400, John Ferlan wrote:
On 06/23/2017 09:33 AM, Peter Krempa wrote:
> The helper methods for actually accessing the storage objects don't
> really belong to the main storage driver implementation file. Split them
> out.
> ---
> po/POTFILES.in | 1 +
> src/Makefile.am | 1 +
> src/qemu/qemu_domain.c | 1 +
> src/qemu/qemu_driver.c | 1 +
> src/security/virt-aa-helper.c | 2 +-
> src/storage/storage_driver.c | 551 +--------------------------------------
> src/storage/storage_driver.h | 28 --
> src/storage/storage_source.c | 585 ++++++++++++++++++++++++++++++++++++++++++
> src/storage/storage_source.h | 53 ++++
> tests/virstoragetest.c | 1 +
> 10 files changed, 645 insertions(+), 579 deletions(-)
> create mode 100644 src/storage/storage_source.c
> create mode 100644 src/storage/storage_source.h
>
Since all of the helpers being moved are prefixed with virStorageFile
why not "storage_file.{c,h}"? I realize the helpers are all operating on
virStorageSourcePtr. Is it perhaps because being too close to
virstoragefile.{c,h}?
The thing is that the virStorageSource does not necessarily need to be a
file so I'd eventually like to rename those helpers, so I'll stick with
this filename for now.