On 02/15/2016 02:37 PM, John Ferlan wrote:
Before disappearing too far down the rabbit hole...
My recent foray into qemu_command.c to split out qemu_parse_command.c
got me thinking that the module could use quite a bit of a reorganization.
It's about 11,400 lines of all sorts of various functions. This started out
as an attempt to order functions as they are used, but started turning into
extracting certain API's/Helpers into other qemu_*.c modules.
There's still quite a bit to do, but rather than hold onto it too long
I figured I'd send what I have so far now (and keep working through while
waiting for reviews).
This is essentially all code motion with some function renames along the way.
John Ferlan (12):
qemu-command: Move qemuBuildTPMBackendStr
qemu-command: Move qemuVirCommandGetFDSet
qemu-command: Move qemuBuildTPMDevStr
qemu-command: Move qemuVirCommandGetDevSet
qemu: Move qemuPhysIfaceConnect to qemu_interface.c and rename
qemu: Move qemuNetworkIfaceConnect to qemu_interface.c and rename
qemu-command: Move qemuDomainSupports* functions
qemu-command: Move qemuDomain*Address* functions to qemu_domain.c
qemu-command: Move remaining qemuDomain* functions
qemu-command: Move and rename qemuOpenVhostNet
qemu-command: Move qemuNetworkPrepareDevices
qemu-command: Move qemuAssign*Alias* API's into their own module
po/POTFILES.in | 2 +
src/Makefile.am | 1 +
src/qemu/qemu_assign_alias.c | 468 +++++++
src/qemu/qemu_assign_alias.h | 60 +
src/qemu/qemu_command.c | 3073 +++++-------------------------------------
src/qemu/qemu_command.h | 48 -
src/qemu/qemu_domain.c | 1646 ++++++++++++++++++++++
src/qemu/qemu_domain.h | 25 +
src/qemu/qemu_driver.c | 1 +
src/qemu/qemu_hotplug.c | 19 +-
src/qemu/qemu_interface.c | 378 ++++++
src/qemu/qemu_interface.h | 22 +
src/qemu/qemu_process.c | 56 +-
tests/qemuhotplugtest.c | 1 +
tests/qemuxml2argvtest.c | 1 +
15 files changed, 2978 insertions(+), 2823 deletions(-)
create mode 100644 src/qemu/qemu_assign_alias.c
create mode 100644 src/qemu/qemu_assign_alias.h
I changed all the prefixes from 'qemu-command:' to just 'qemu:'
I modified patch 8 to create qemu_domain_address.{c,h}
I modified patch 12 to rename from qemu_assign_alias.{c,h} to just
qemu_alias.{c,h}... Also moved the qemuDomainDeviceAliasIndex in...
I moved patched 9 to after patch 12 (simplified some things and then
moved the functions into corresponding modules).
Went back and made sure each step compiled, passed make check, and make
syntax-check
Pushed...
Thanks for the review... On to the next pile of code motion...
John