On 2/14/20 1:52 PM, Daniel P. Berrangé wrote:
Historically threads are given a name based on the C function,
and this name is just used inside libvirt. With OS level thread
naming this name is now visible to debuggers, but also has to
fit in 15 characters on Linux, so function names are too long
in some cases.
Signed-off-by: Daniel P. Berrangé <berrange(a)redhat.com>
---
src/libxl/libxl_domain.c | 10 ++++++----
src/libxl/libxl_migration.c | 23 ++++++++++++++++++-----
src/lxc/lxc_fuse.c | 4 ++--
src/node_device/node_device_udev.c | 7 ++++---
src/nwfilter/nwfilter_dhcpsnoop.c | 11 ++++++-----
src/nwfilter/nwfilter_learnipaddr.c | 10 ++++++----
src/qemu/qemu_driver.c | 3 ++-
src/qemu/qemu_migration.c | 8 +++++---
src/qemu/qemu_process.c | 17 ++++++++++++-----
src/remote/remote_daemon.c | 9 ++++++---
src/rpc/virnetserver.c | 9 +++++----
src/storage/storage_backend_scsi.c | 4 ++--
src/storage/storage_driver.c | 4 ++--
src/util/vircommand.c | 5 +++--
src/util/virfdstream.c | 10 ++++++----
src/util/virnodesuspend.c | 8 +++++---
src/util/virthreadpool.c | 14 ++++++++++----
src/util/virthreadpool.h | 2 +-
18 files changed, 101 insertions(+), 57 deletions(-)
Reviewed-by: Michal Privoznik <mprivozn(a)redhat.com>
Michal