[libvirt] [PATCH] docs: Space out entries in news.html
by Peter Krempa
The header for the news entry blends together with the text and other
entries. This patch tries to space them out somewhat for better visual
separation.
Signed-off-by: Peter Krempa <pkrempa(a)redhat.com>
---
You can see the difference here:
https://github.com/pipo/libvirt/blob/screenshots/before.png
https://github.com/pipo/libvirt/blob/screenshots/after.png
docs/libvirt.css | 15 +++++++++++++++
docs/news-html.xsl | 13 +++++++++----
2 files changed, 24 insertions(+), 4 deletions(-)
diff --git a/docs/libvirt.css b/docs/libvirt.css
index 4c7afc4042..e44ef616d8 100644
--- a/docs/libvirt.css
+++ b/docs/libvirt.css
@@ -591,3 +591,18 @@ td.enumvalue {
.deprecatedhv {
color: darkred;
}
+
+ul.news-section {
+ margin-top: 0.5em;
+}
+
+ul.news-section li dl dt {
+ margin: 0;
+}
+
+ul.news-section li dl dd {
+ margin-left: 1em;
+ margin-right: 0;
+ margin-top: 0.5em;
+ margin-bottom: 0.5em;
+}
diff --git a/docs/news-html.xsl b/docs/news-html.xsl
index 4d40798028..fb0178f9e2 100644
--- a/docs/news-html.xsl
+++ b/docs/news-html.xsl
@@ -58,7 +58,7 @@
<xsl:value-of select="@title"/>
</strong>
<xsl:if test="*">
- <ul>
+ <ul class="news-section">
<xsl:apply-templates select="change"/>
</ul>
</xsl:if>
@@ -68,8 +68,14 @@
<!-- Change -->
<xsl:template match="change">
<li>
- <xsl:apply-templates select="summary"/>
- <xsl:apply-templates select="description"/>
+ <dl>
+ <dt>
+ <xsl:apply-templates select="summary"/>
+ </dt>
+ <dd>
+ <xsl:apply-templates select="description"/>
+ </dd>
+ </dl>
</li>
</xsl:template>
@@ -80,7 +86,6 @@
<!-- Change description -->
<xsl:template match="description">
- <br/>
<xsl:apply-templates/>
</xsl:template>
--
2.21.0
5 years, 5 months
[libvirt] [PATCH] Revert "news: Document removal of qemu commandline parsing"
by Peter Krempa
Jano probably based his branch on top of mine and didn't notice
when I moved the section up slightly and thus git applied it again.
Keep only the instance followin the new features section.
This reverts commit 9c68bb4a5c2c8c050e531533e5188a637ba1dd9f.
Signed-off-by: Peter Krempa <pkrempa(a)redhat.com>
---
Pushed under the trivial rule.
docs/news.xml | 12 ------------
1 file changed, 12 deletions(-)
diff --git a/docs/news.xml b/docs/news.xml
index 681e9a60a3..cada389092 100644
--- a/docs/news.xml
+++ b/docs/news.xml
@@ -67,18 +67,6 @@
</section>
<section title="Bug fixes">
</section>
- <section title="Removed features">
- <change>
- <summary>
- qemu: Remove support for virDomainQemuAttach and virConnectDomainXMLFromNative APIs
- </summary>
- <description>
- The qemu implementations for the APIs mentioned above were removed
- and the APIs now return error. The implementation was stale for a
- long time and did not allow working with moder use of qemu in libvirt.
- </description>
- </change>
- </section>
</release>
<release version="v5.4.0" date="2019-06-03">
<section title="Security">
--
2.21.0
5 years, 5 months
[libvirt] [PATCH] rpc: virnetlibsshsession: update deprecated functions
by Pavel Hrdina
In libssh 0.9.0 functions ssh_is_server_known and ssh_write_knownhost
are marked as deprecated.
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1722735
Signed-off-by: Pavel Hrdina <phrdina(a)redhat.com>
---
m4/virt-libssh.m4 | 8 ++++++++
src/rpc/virnetlibsshsession.c | 4 ++--
2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/m4/virt-libssh.m4 b/m4/virt-libssh.m4
index 01c3b75c72..132447da16 100644
--- a/m4/virt-libssh.m4
+++ b/m4/virt-libssh.m4
@@ -33,6 +33,14 @@ AC_DEFUN([LIBVIRT_CHECK_LIBSSH],[
[],
[AC_DEFINE_UNQUOTED([ssh_get_server_publickey], [ssh_get_publickey],
[ssh_get_publickey is deprecated and replaced by ssh_get_server_publickey.])])
+ AC_CHECK_FUNC([ssh_session_is_known_server],
+ [],
+ [AC_DEFINE_UNQUOTED([ssh_session_is_known_server], [ssh_is_server_known],
+ [ssh_is_server_known is deprecated and replaced by ssh_session_is_known_server.])])
+ AC_CHECK_FUNC([ssh_session_update_known_hosts],
+ [],
+ [AC_DEFINE_UNQUOTED([ssh_session_update_known_hosts], [ssh_write_knownhost],
+ [ssh_write_knownhost is deprecated and replaced by ssh_session_update_known_hosts.])])
CFLAGS="$old_CFLAGS"
LIBS="$old_LIBS"
fi
diff --git a/src/rpc/virnetlibsshsession.c b/src/rpc/virnetlibsshsession.c
index 486437e7bf..093ac29071 100644
--- a/src/rpc/virnetlibsshsession.c
+++ b/src/rpc/virnetlibsshsession.c
@@ -284,7 +284,7 @@ virNetLibsshCheckHostKey(virNetLibsshSessionPtr sess)
if (sess->hostKeyVerify == VIR_NET_LIBSSH_HOSTKEY_VERIFY_IGNORE)
return 0;
- state = ssh_is_server_known(sess->session);
+ state = ssh_session_is_known_server(sess->session);
switch (state) {
case SSH_SERVER_KNOWN_OK:
@@ -378,7 +378,7 @@ virNetLibsshCheckHostKey(virNetLibsshSessionPtr sess)
/* write the host key file, if specified */
if (sess->knownHostsFile) {
- if (ssh_write_knownhost(sess->session) < 0) {
+ if (ssh_session_update_known_hosts(sess->session) < 0) {
errmsg = ssh_get_error(sess->session);
virReportError(VIR_ERR_LIBSSH,
_("failed to write known_host file '%s': %s"),
--
2.21.0
5 years, 5 months
[libvirt] [PATCH] Fix 'validate' typo in comments
by Jonathon Jongsma
Signed-off-by: Jonathon Jongsma <jjongsma(a)redhat.com>
---
src/conf/domain_conf.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c
index d06e094b11..8604ba63d4 100644
--- a/src/conf/domain_conf.c
+++ b/src/conf/domain_conf.c
@@ -21375,7 +21375,7 @@ virDomainObjParseXML(xmlDocPtr xml,
if (virDomainDefPostParse(obj->def, caps, flags, xmlopt, parseOpaque) < 0)
goto error;
- /* valdiate configuration */
+ /* validate configuration */
if (virDomainDefValidate(obj->def, caps, flags, xmlopt) < 0)
goto error;
@@ -21465,7 +21465,7 @@ virDomainDefParseNode(xmlDocPtr xml,
if (virDomainDefPostParse(def, caps, flags, xmlopt, parseOpaque) < 0)
goto cleanup;
- /* valdiate configuration */
+ /* validate configuration */
if (virDomainDefValidate(def, caps, flags, xmlopt) < 0)
goto cleanup;
--
2.20.1
5 years, 5 months
[libvirt] [PATCH 0/3] snapshots: Allow <seclabel> for snapshot disk source
by Peter Krempa
This is just a schema improvement, the code actually already does
everything.
Peter Krempa (3):
docs: snapshot: Encourage people ot use disk 'target' to refer to
disks
docs: schemas: Add 'seclabel' for external disk snapshot
tests: domainsnapshotxml2xml: make 'disk-seclabel' test operational
docs/formatsnapshot.html.in | 18 +++++++++++++++---
docs/schemas/domainsnapshot.rng | 6 ++++++
...-seclabel-invalid.xml => disk-seclabel.xml} | 0
.../domainsnapshotxml2xmlout/disk-seclabel.xml | 15 +++++++++++++++
tests/domainsnapshotxml2xmltest.c | 1 +
5 files changed, 37 insertions(+), 3 deletions(-)
rename tests/domainsnapshotxml2xmlin/{disk-seclabel-invalid.xml => disk-seclabel.xml} (100%)
create mode 100644 tests/domainsnapshotxml2xmlout/disk-seclabel.xml
--
2.21.0
5 years, 5 months
[libvirt] [PATCH 00/15] qemu: Add possibility to control qemu capabilities for debug (blockdev-add saga spin-off)
by Peter Krempa
While this is not strictly required for blockdev to work it was created
as a part of the testing (and possibly regression mitigation) effort.
These patches introduce the option to add or remove qemu capabilities
via the qemu XML namespace custom elements and remove features via
qemu.conf.
This series depends (very slightly) on the series deleting qemu parsing.
To make applying it easy I'd sugges you fetrch everything needed by:
git fetch https://github.com/pipo/libvirt.git features-filter
Peter Krempa (15):
qemu: Rename qemuDomainCmdlineDefPtr to qemuDomainXmlNsDefPtr
qemu: Move qemuDomainXmlNsDef(Free) from qemu_conf.(ch)
qemu: domain: Use virStringListFreeCount in qemuDomainXmlNsDefFree
qemu: Extract parsing of qemu namespace arguments into separate
function
qemu: Extract parsing of qemu namespace env vars into separate
function
qemu: Refactor qemuDomainDefNamespaceParse
qemu: domain: Split out commandline namespace data formatting
conf: Add taint flag for custom hypervisor features
qemu: Add support for controling qemu capabilities via the qemu XML
namespace
qemu: domain: Add support for modifying qemu capability list via qemu
namespace
tests: qemuxml2argv: Modernize and fork 'qemu-ns' test
tests: qemuxml2argv: Test qemu namespace capability tweaking
qemu: Remove unused var 'corestr' from virQEMUDriverConfigLoadFile
qemu: conf: Add debug option to allow disabling qemu capabilities
qemu: Implement support for 'capability_filters' config option
docs/drvqemu.html.in | 30 ++
docs/schemas/domaincommon.rng | 19 ++
src/conf/domain_conf.c | 1 +
src/conf/domain_conf.h | 1 +
src/qemu/libvirtd_qemu.aug | 3 +
src/qemu/qemu.conf | 7 +
src/qemu/qemu_command.c | 16 +-
src/qemu/qemu_conf.c | 39 ++-
src/qemu/qemu_conf.h | 17 +-
src/qemu/qemu_domain.c | 285 +++++++++++++-----
src/qemu/qemu_domain.h | 19 ++
src/qemu/qemu_process.c | 55 ++++
src/qemu/test_libvirtd_qemu.aug.in | 3 +
tests/qemuxml2argvdata/qemu-ns.args | 33 --
.../qemu-ns.x86_64-4.0.0.args | 41 +++
.../qemu-ns.x86_64-latest.args | 41 +++
tests/qemuxml2argvdata/qemu-ns.xml | 5 +
tests/qemuxml2argvtest.c | 3 +-
18 files changed, 458 insertions(+), 160 deletions(-)
delete mode 100644 tests/qemuxml2argvdata/qemu-ns.args
create mode 100644 tests/qemuxml2argvdata/qemu-ns.x86_64-4.0.0.args
create mode 100644 tests/qemuxml2argvdata/qemu-ns.x86_64-latest.args
--
2.21.0
5 years, 5 months
[libvirt] [PATCH] docs: Fix Blog Planet links
by Martin Kletzander
They were pointing to the blogs instead, now they point the articles.
Signed-off-by: Martin Kletzander <mkletzan(a)redhat.com>
---
Pushed as trivial-and-thoroughly-tested.
docs/js/main.js | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/docs/js/main.js b/docs/js/main.js
index e48e95075cf6..2edc62830453 100644
--- a/docs/js/main.js
+++ b/docs/js/main.js
@@ -116,10 +116,10 @@ function fetchRSS() {
var name = e.querySelector("author > name").textContent;
var title = e.querySelector("title").textContent;
var updated = e.querySelector("updated").textContent;
- var uri = e.querySelector("author > uri").textContent;
+ var link = e.querySelector("link").attributes.href.textContent;
var a = document.createElement("a");
- a.href = uri;
+ a.href = link;
a.innerText = title;
var dt = document.createElement("dt");
--
2.22.0
5 years, 5 months
[libvirt] [PATCH] remote: refactor how unprivileged user session connection is identified
by Daniel P. Berrangé
Currently the VIR_DRV_OPEN_REMOTE_USER flag is only set when we identify
that we're connecting to a local libvirtd daemon. We would like to be
able to set that even if connecting to a remote libvirtd daemon. This
entails refactoring the conditional check.
One subtle change is that the VIR_DRV_OPEN_REMOTE_USER is now set when
the test+XXX:// URI is used, even if a servername is present. This has
no effect in this patch, but will later.
Signed-off-by: Daniel P. Berrangé <berrange(a)redhat.com>
---
src/remote/remote_driver.c | 26 ++++++++++++++++++--------
1 file changed, 18 insertions(+), 8 deletions(-)
diff --git a/src/remote/remote_driver.c b/src/remote/remote_driver.c
index a95781a797..e1eaa56230 100644
--- a/src/remote/remote_driver.c
+++ b/src/remote/remote_driver.c
@@ -1390,25 +1390,35 @@ remoteConnectOpen(virConnectPtr conn,
rflags |= VIR_DRV_OPEN_REMOTE_RO;
/*
- * If no servername is given, and no +XXX
- * transport is listed, or transport is unix,
- * and path is /session, and uid is unprivileged
- * then auto-spawn a daemon.
+ * User session daemon is used for
+ *
+ * - Any URI with /session suffix
+ * - Test driver, if a protocol is given
+ *
+ * provided we are running non-root
*/
if (conn->uri &&
- !conn->uri->server &&
conn->uri->path &&
conn->uri->scheme &&
- (transport == NULL || STREQ(transport, "unix")) &&
(STREQ(conn->uri->path, "/session") ||
STRPREFIX(conn->uri->scheme, "test+")) &&
geteuid() > 0) {
- VIR_DEBUG("Auto-spawn user daemon instance");
+ VIR_DEBUG("User session daemon required");
rflags |= VIR_DRV_OPEN_REMOTE_USER;
+
+ /*
+ * Furthermore if no servername is given, and no +XXX
+ * transport is listed, or transport is unix,
+ * and uid is unprivileged then auto-spawn a daemon.
+ */
if (!virIsSUID() &&
+ !conn->uri->server &&
+ (transport == NULL || STREQ(transport, "unix")) &&
(!autostart ||
- STRNEQ(autostart, "0")))
+ STRNEQ(autostart, "0"))) {
+ VIR_DEBUG("Try daemon autostart");
rflags |= VIR_DRV_OPEN_REMOTE_AUTOSTART;
+ }
}
/*
--
2.21.0
5 years, 5 months
[libvirt] [PATCH 0/2] error: Allow better reporting of errors in some nested cases
by Peter Krempa
Peter Krempa (2):
util: error: Add API for prefixing last set error with a string
qemu: process: Report better error when virtlogd connection fails
cfg.mk | 1 +
src/libvirt_private.syms | 1 +
src/qemu/qemu_process.c | 4 +++-
src/util/virerror.c | 38 ++++++++++++++++++++++++++++++++++++++
src/util/virerror.h | 3 +++
5 files changed, 46 insertions(+), 1 deletion(-)
--
2.21.0
5 years, 5 months
[libvirt] [PATCH] Revert "spec: Bump minimum supported Fedora version to 29"
by Ján Tomko
This reverts commit 8a1179831b5edc0a3590489eda693914fc0ff94f.
It bumped the version prematurely, before the EOL of Fedora 28.
Morover, this arbitrary bump did not let us perform any cleanups in the
specfile.
Signed-off-by: Ján Tomko <jtomko(a)redhat.com>
---
libvirt.spec.in | 2 +-
mingw-libvirt.spec.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/libvirt.spec.in b/libvirt.spec.in
index 78b7f43934..5c0b4a7605 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -4,7 +4,7 @@
# that's still supported by the vendor. It may work on other distros
# or versions, but no effort will be made to ensure that going forward.
%define min_rhel 7
-%define min_fedora 29
+%define min_fedora 28
%if (0%{?fedora} && 0%{?fedora} >= %{min_fedora}) || (0%{?rhel} && 0%{?rhel} >= %{min_rhel})
%define supported_platform 1
diff --git a/mingw-libvirt.spec.in b/mingw-libvirt.spec.in
index 9add033669..8a96ea914c 100644
--- a/mingw-libvirt.spec.in
+++ b/mingw-libvirt.spec.in
@@ -3,7 +3,7 @@
# This spec file assumes you are building on a Fedora version
# that's still supported by the vendor. It may work on other distros
# or versions, but no effort will be made to ensure that going forward.
-%define min_fedora 29
+%define min_fedora 28
%if 0%{?fedora} && 0%{?fedora} >= %{min_fedora}
%define supported_platform 1
--
2.20.1
5 years, 5 months