[libvirt] [PATCH v7 0/9] Add setting CPU features (CPUID) with libxenlight driver.
by Marek Marczykowski-Górecki
Add support for CPUID setting based on <cpu> element. Since libxl format
support only adjusting specific bits over host CPU, only
mode='host-passthrough' is supported - other values are rejected (including
default 'custom'). This will break some configurations working before (bare
<cpu> element with for example NUMA configuration), but libxl driver never
supported full 'custom' mode - it was silently ignored, which might lead to
some unexpected effects.
Since mode='host-passthrough' is now necessary to specify CPU options, do not
enable nested HVM feature by mere presence of this element, require also
enabling it in libxl.conf. Nested HVM is still in "preview" state, so better be
explicit here.
v2 of this patch series:
https://www.redhat.com/archives/libvir-list/2017-July/msg00050.html
v3 of this patch series:
https://www.redhat.com/archives/libvir-list/2017-December/msg00314.html
v4 of this patch series:
https://www.redhat.com/archives/libvir-list/2018-February/msg00504.html
v5 of this patch series:
https://www.redhat.com/archives/libvir-list/2018-March/msg00796.html
v6 of this patch series:
https://www.redhat.com/archives/libvir-list/2018-March/msg01310.html
Marek Marczykowski-Górecki (9):
libxl: fix libxlDriverConfigDispose for partially constructed object
libxl: pass driver config to libxlMakeDomBuildInfo
libxl: warn about ignored CPU mode=custom
libxl: do not enable nested HVM unless global nested_hvm option enabled
xenconfig: do not override def->cpu if already set elsewhere
libxl: add support for CPUID features policy
tests: check CPU features handling in libxl driver
xenconfig: add CPUID handling to domXML <-> xl.cfg conversion
tests: add test case for CPUID in xenconfig driver
src/libxl/libvirtd_libxl.aug | 2 +-
src/libxl/libxl.conf | 8 +-
src/libxl/libxl_conf.c | 66 +++-
src/libxl/libxl_conf.h | 6 +-
src/libxl/libxl_domain.c | 2 +-
src/libxl/test_libvirtd_libxl.aug.in | 1 +-
src/xenconfig/xen_xl.c | 236 ++++++++++++++--
src/xenconfig/xen_xl.h | 2 +-
tests/libxlxml2domconfigdata/fullvirt-cpuid.json | 60 ++++-
tests/libxlxml2domconfigdata/fullvirt-cpuid.xml | 34 ++-
tests/libxlxml2domconfigtest.c | 27 +-
tests/virmocklibxl.c | 31 ++-
tests/xlconfigdata/test-fullvirt-cpuid.cfg | 25 ++-
tests/xlconfigdata/test-fullvirt-cpuid.xml | 36 ++-
tests/xlconfigtest.c | 1 +-
15 files changed, 492 insertions(+), 45 deletions(-)
create mode 100644 tests/libxlxml2domconfigdata/fullvirt-cpuid.json
create mode 100644 tests/libxlxml2domconfigdata/fullvirt-cpuid.xml
create mode 100644 tests/xlconfigdata/test-fullvirt-cpuid.cfg
create mode 100644 tests/xlconfigdata/test-fullvirt-cpuid.xml
base-commit: dffe584aa4194b0667924632e9e1ae12c5520956
--
git-series 0.9.1
6 years, 7 months
[libvirt] [PATCH v2 0/2] Fix vmware driver for VMware Fusion 10
by Rainer Müller
These changes were required to get VMware Fusion working at all.
I tested with VMware Fusion 10.1.1 on macOS 10.12 Sierra.
I am not sure whether calling virCapabilitiesInitCaches() makes sense at
all on macOS. This function looks highly specific to Linux as it relies
on /sys/devices/system, so it should probably be wrapped with an
appropriate #ifdef. I do not feel proficient enough with the libvirt
internals to make this change, though.
v1 was here:
https://www.redhat.com/archives/libvir-list/2018-April/msg00087.html
diff to v1:
- Fix a possible segfault when vmrun is not found in PATH.
Rainer Müller (2):
vmware: Fix initialization of VMware Fusion
vmware: Failures in cache info init are non-fatal
src/vmware/vmware_conf.c | 7 ++++++-
src/vmware/vmware_driver.c | 11 ++++++++++-
2 files changed, 16 insertions(+), 2 deletions(-)
--
2.17.0
6 years, 7 months
[libvirt] [jenkins-ci PATCH v3 0/3] Mostly drop CentOS 6
by Andrea Bolognani
This applies on top of
https://www.redhat.com/archives/libvir-list/2018-April/msg01526.html
Changes from [v2]:
* several patches have been pushed already;
* define the libvirt-master-build-website job using the newly
variants-enabled generic-build-job template;
* add 'mingw_machines' variable along with 'all_machines'
and 'rpm_machines'.
Changes from [v1]:
* instead of dropping CentOS 6 altogether, simply stop building
pretty much all projects on it;
* introduce a new job type specifically for whatever little
stuff we need to ensure still works on CentOS 6;
* the end result is still a nice cleanup thanks to not repeating
the list of machines all over the place; moreover, the
message about our support of the OS is very clear because it
disappears from all but one page on the CI web interface.
[v1] https://www.redhat.com/archives/libvir-list/2018-April/msg00453.html
[v2] https://www.redhat.com/archives/libvir-list/2018-April/msg01051.html
Andrea Bolognani (3):
jobs: Introduce machine groups
guests: Introduce libvirt+website project
projects: Add libvirt-master-build-website job
guests/host_vars/libvirt-centos-6/main.yml | 3 +++
guests/vars/projects/libvirt+website.yml | 5 ++++
jobs/defaults.yaml | 16 ++++++++++++
projects/libosinfo.yaml | 16 ++----------
projects/libvirt-cim.yaml | 6 +----
projects/libvirt-dbus.yaml | 6 +----
projects/libvirt-glib.yaml | 22 +++-------------
projects/libvirt-go-xml.yaml | 10 +------
projects/libvirt-go.yaml | 10 +------
projects/libvirt-perl.yaml | 16 ++----------
projects/libvirt-python.yaml | 16 ++----------
projects/libvirt.yaml | 42 ++++++++++++++++--------------
projects/osinfo-db-tools.yaml | 16 ++----------
projects/osinfo-db.yaml | 16 ++----------
projects/virt-viewer.yaml | 22 +++-------------
15 files changed, 69 insertions(+), 153 deletions(-)
create mode 100644 guests/vars/projects/libvirt+website.yml
--
2.14.3
6 years, 7 months
[libvirt] [jenkins-ci PATCH 0/3] Introduce variants and use them for MinGW
by Andrea Bolognani
Andrea Bolognani (3):
jobs: Introduce variants
jobs: Tweak autotools-mingw-job template
jobs: Drop autotools-mingw-job
jobs/autotools.yaml | 94 ++++------------------------------------------
jobs/defaults.yaml | 17 +++++++++
jobs/generic.yaml | 16 ++++----
jobs/go.yaml | 8 ++--
jobs/perl-makemaker.yaml | 12 +++---
jobs/perl-modulebuild.yaml | 12 +++---
jobs/python-distutils.yaml | 12 +++---
projects/libvirt-glib.yaml | 12 +++++-
projects/libvirt.yaml | 12 +++++-
projects/virt-viewer.yaml | 12 +++++-
10 files changed, 88 insertions(+), 119 deletions(-)
--
2.14.3
6 years, 7 months
[libvirt] [PATCH v2 0/5] virClassNew rework
by Michal Privoznik
Patches ACKed from v1 are pushed now (mostly, unless they don't make
sense alone).
diff to v1:
- Expanded 1/5 to rename remote_protocol.x too,
- Extended VIR_CLASS_NEW to be a standalone macro
- Switched to compile time check instead of runtime one in 4/5
Michal Privoznik (5):
datatypes: Rename @parent to @parentName in virNodeDevice
src: Unify virObject member name
virobject: Introduce VIR_CLASS_NEW() macro
virobject: Check if @parent is the first member in class
cfg.mk: Introduce syntax-check rule to prefer VIR_CLASS_NEW
cfg.mk | 8 ++
src/access/viraccessmanager.c | 7 +-
src/bhyve/bhyve_conf.c | 9 +-
src/conf/capabilities.c | 7 +-
src/conf/domain_capabilities.c | 15 +--
src/conf/domain_conf.c | 26 ++---
src/conf/domain_event.c | 169 ++++++++------------------------
src/conf/network_event.c | 18 ++--
src/conf/node_device_event.c | 27 ++---
src/conf/object_event.c | 16 +--
src/conf/secret_event.c | 27 ++---
src/conf/storage_event.c | 27 ++---
src/conf/virdomainobjlist.c | 7 +-
src/conf/virinterfaceobj.c | 14 +--
src/conf/virnetworkobj.c | 14 +--
src/conf/virnodedeviceobj.c | 16 +--
src/conf/virsecretobj.c | 14 +--
src/conf/virstorageobj.c | 28 ++----
src/datatypes.c | 13 +--
src/datatypes.h | 30 +++---
src/interface/interface_backend_netcf.c | 8 +-
src/libvirt-admin.c | 10 +-
src/libvirt-domain-snapshot.c | 2 +-
src/libvirt-domain.c | 2 +-
src/libvirt-host.c | 2 +-
src/libvirt-interface.c | 2 +-
src/libvirt-network.c | 2 +-
src/libvirt-nodedev.c | 8 +-
src/libvirt-nwfilter.c | 2 +-
src/libvirt-secret.c | 2 +-
src/libvirt-storage.c | 4 +-
src/libvirt-stream.c | 2 +-
src/libxl/libxl_conf.c | 7 +-
src/libxl/libxl_domain.c | 7 +-
src/libxl/libxl_migration.c | 7 +-
src/logging/log_handler.c | 7 +-
src/lxc/lxc_conf.c | 7 +-
src/lxc/lxc_monitor.c | 7 +-
src/node_device/node_device_driver.c | 4 +-
src/node_device/node_device_udev.c | 7 +-
src/qemu/qemu_agent.c | 7 +-
src/qemu/qemu_capabilities.c | 9 +-
src/qemu/qemu_conf.c | 11 +--
src/qemu/qemu_domain.c | 63 ++++--------
src/qemu/qemu_monitor.c | 7 +-
src/remote/remote_daemon_dispatch.c | 4 +-
src/remote/remote_protocol.x | 2 +-
src/remote_protocol-structs | 2 +-
src/rpc/virkeepalive.c | 7 +-
src/rpc/virnetclient.c | 7 +-
src/rpc/virnetclientprogram.c | 9 +-
src/rpc/virnetclientstream.c | 7 +-
src/rpc/virnetdaemon.c | 7 +-
src/rpc/virnetlibsshsession.c | 7 +-
src/rpc/virnetsaslcontext.c | 14 +--
src/rpc/virnetserver.c | 7 +-
src/rpc/virnetserverclient.c | 7 +-
src/rpc/virnetserverprogram.c | 9 +-
src/rpc/virnetserverservice.c | 9 +-
src/rpc/virnetsocket.c | 7 +-
src/rpc/virnetsshsession.c | 7 +-
src/rpc/virnettlscontext.c | 14 +--
src/security/security_manager.c | 7 +-
src/test/test_driver.c | 6 +-
src/util/virclosecallbacks.c | 11 +--
src/util/virdnsmasq.c | 10 +-
src/util/virfdstream.c | 7 +-
src/util/virfilecache.c | 9 +-
src/util/virhash.c | 12 +--
src/util/virhostdev.c | 7 +-
src/util/viridentity.c | 7 +-
src/util/virmacmap.c | 7 +-
src/util/virmdev.c | 7 +-
src/util/virobject.c | 14 +--
src/util/virobject.h | 11 +++
src/util/virpci.c | 7 +-
src/util/virportallocator.c | 7 +-
src/util/virresctrl.c | 14 +--
src/util/virscsi.c | 7 +-
src/util/virscsivhost.c | 7 +-
src/util/virusb.c | 7 +-
src/vbox/vbox_common.c | 7 +-
src/vz/vz_driver.c | 7 +-
tests/virfilecachetest.c | 9 +-
84 files changed, 322 insertions(+), 679 deletions(-)
--
2.16.1
6 years, 7 months
[libvirt] [PATCH] domain: avoid slash characters to the new domain name.
by Julio Faracco
The 'domrename' command needs to check if the new domain name contains
the slash character. This character is not accepted by libvirt XML
definition because it is an invalid char (see Cole's commit b1fc6a7b7).
This commit enhace the 'domrename' command adding this check.
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1333232
Signed-off-by: Julio Faracco <jcfaracco(a)gmail.com>
---
src/internal.h | 9 +++++++++
src/libvirt-domain.c | 1 +
2 files changed, 10 insertions(+)
diff --git a/src/internal.h b/src/internal.h
index 1760e3b69..e976b1caa 100644
--- a/src/internal.h
+++ b/src/internal.h
@@ -484,6 +484,15 @@
goto label; \
} \
} while (0)
+# define virCheckNonSlashGoto(argname, label) \
+ do { \
+ if (strchr(argname, '/')) { \
+ virReportInvalidArg(ctl, \
+ _("name %s cannot contain '/'"), \
+ argname); \
+ goto label; \
+ } \
+ } while (0)
diff --git a/src/libvirt-domain.c b/src/libvirt-domain.c
index 63d2ae23d..47bc59b11 100644
--- a/src/libvirt-domain.c
+++ b/src/libvirt-domain.c
@@ -8536,6 +8536,7 @@ virDomainRename(virDomainPtr dom,
virResetLastError();
virCheckDomainReturn(dom, -1);
virCheckNonEmptyStringArgGoto(new_name, error);
+ virCheckNonSlashGoto(new_name, error);
virCheckReadOnlyGoto(dom->conn->flags, error);
if (dom->conn->driver->domainRename) {
--
2.14.1
6 years, 7 months
[libvirt] [PATCHv2 0/4] qemu: enable sandbox whitelist by default
by Ján Tomko
v1: https://www.redhat.com/archives/libvir-list/2018-March/msg01965.html
https://bugzilla.redhat.com/show_bug.cgi?id=1492597
v2:
* also deny resource control
* split out and refactor the command line building
* be explicit about denying the obsolete syscalls
Ján Tomko (4):
Introduce QEMU_CAPS_SECCOMP_BLACKLIST
Introduce qemuBuildSeccompSandboxCommandLine
Refactor qemuBuildSeccompSandboxCommandLine
qemu: deny privilege elevation and spawn in seccomp
src/qemu/qemu.conf | 7 ++--
src/qemu/qemu_capabilities.c | 2 +
src/qemu/qemu_capabilities.h | 1 +
src/qemu/qemu_command.c | 46 +++++++++++++++++-----
tests/qemucapabilitiesdata/caps_2.11.0.s390x.xml | 1 +
tests/qemucapabilitiesdata/caps_2.12.0.aarch64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.12.0.ppc64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.12.0.s390x.xml | 1 +
tests/qemucapabilitiesdata/caps_2.12.0.x86_64.xml | 1 +
tests/qemuxml2argvdata/minimal-sandbox.args | 29 ++++++++++++++
tests/qemuxml2argvdata/minimal-sandbox.xml | 34 ++++++++++++++++
tests/qemuxml2argvtest.c | 11 ++++++
12 files changed, 123 insertions(+), 12 deletions(-)
create mode 100644 tests/qemuxml2argvdata/minimal-sandbox.args
create mode 100644 tests/qemuxml2argvdata/minimal-sandbox.xml
--
2.16.1
6 years, 7 months
[libvirt] [jenkins-ci PATCH v2 0/6] Mostly drop CentOS 6
by Andrea Bolognani
Changes from [v1]:
* instead of dropping CentOS 6 altogether, simply stop building
pretty much all projects on it;
* introduce a new job type specifically for whatever little
stuff we need to ensure still works on CentOS 6;
* the end result is still a nice cleanup thanks to not repeating
the list of machines all over the place; moreover, the
message about our support of the OS is very clear because it
disappears from all but one page on the CI web interface.
[v1] https://www.redhat.com/archives/libvir-list/2018-April/msg00453.html
Andrea Bolognani (6):
jobs: Introduce autotools-website-job
guests: Introduce libvirt+website project
projects: Add libvirt-master-website job
projects: Stop building on CentOS 6
guests: Drop projects from CentOS 6
jobs: Introduce {all_machines} and {rpm_machines}
guests/host_vars/libvirt-centos-6/main.yml | 5 +--
guests/vars/projects/libvirt+website.yml | 5 +++
jobs/autotools.yaml | 67 ++++++++++++++++++++++++++++++
jobs/defaults.yaml | 14 +++++++
projects/libosinfo.yaml | 16 +------
projects/libvirt-cim.yaml | 7 +---
projects/libvirt-glib.yaml | 16 +------
projects/libvirt-go-xml.yaml | 10 +----
projects/libvirt-go.yaml | 10 +----
projects/libvirt-perl.yaml | 17 +-------
projects/libvirt-python.yaml | 18 +-------
projects/libvirt.yaml | 34 +++++++--------
projects/osinfo-db-tools.yaml | 16 +------
projects/osinfo-db.yaml | 16 +------
projects/virt-viewer.yaml | 16 +------
15 files changed, 119 insertions(+), 148 deletions(-)
create mode 100644 guests/vars/projects/libvirt+website.yml
--
2.14.3
6 years, 7 months
[libvirt] [PATCH v2 0/5] Enable memory-backend-file.discard-data
by Michal Privoznik
diff to v1:
- Merged two patches into one (5/7 and 6/7 from the original series)
- reworked last patch
- 1/7 from the original series is pushed now
Michal Privoznik (5):
qemu_capabilities: s/ObjectProps/DeviceProps/g
qemu_capabilities: Separate out device props fetching
qemu_monitor: Introduce qemuMonitorGetObjectProps
qemu_capabilities: Introduce QEMU_CAPS_OBJECT_MEMORY_FILE_DISCARD
qemu: Enable memory-backend-file.discard-data whenever possible
src/qemu/qemu_capabilities.c | 267 +++++----
src/qemu/qemu_capabilities.h | 1 +
src/qemu/qemu_command.c | 7 +
src/qemu/qemu_monitor.c | 13 +
src/qemu/qemu_monitor.h | 3 +
src/qemu/qemu_monitor_json.c | 62 ++-
src/qemu/qemu_monitor_json.h | 4 +
.../qemucapabilitiesdata/caps_2.1.1.x86_64.replies | 20 +-
tests/qemucapabilitiesdata/caps_2.1.1.x86_64.xml | 2 +-
.../caps_2.10.0.aarch64.replies | 30 +-
tests/qemucapabilitiesdata/caps_2.10.0.aarch64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.10.0.ppc64.replies | 28 +-
tests/qemucapabilitiesdata/caps_2.10.0.ppc64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.10.0.s390x.replies | 32 +-
tests/qemucapabilitiesdata/caps_2.10.0.s390x.xml | 2 +-
.../caps_2.10.0.x86_64.replies | 540 +++++++++---------
tests/qemucapabilitiesdata/caps_2.10.0.x86_64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.11.0.s390x.replies | 26 +-
tests/qemucapabilitiesdata/caps_2.11.0.s390x.xml | 2 +-
.../caps_2.12.0.aarch64.replies | 24 +-
tests/qemucapabilitiesdata/caps_2.12.0.aarch64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.12.0.ppc64.replies | 22 +-
tests/qemucapabilitiesdata/caps_2.12.0.ppc64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.12.0.s390x.replies | 24 +-
.../caps_2.12.0.x86_64.replies | 612 +++++++++++----------
tests/qemucapabilitiesdata/caps_2.12.0.x86_64.xml | 3 +-
.../qemucapabilitiesdata/caps_2.4.0.x86_64.replies | 20 +-
tests/qemucapabilitiesdata/caps_2.4.0.x86_64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.5.0.x86_64.replies | 22 +-
tests/qemucapabilitiesdata/caps_2.5.0.x86_64.xml | 2 +-
.../caps_2.6.0.aarch64.replies | 30 +-
tests/qemucapabilitiesdata/caps_2.6.0.aarch64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.6.0.ppc64.replies | 28 +-
tests/qemucapabilitiesdata/caps_2.6.0.ppc64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.6.0.x86_64.replies | 22 +-
tests/qemucapabilitiesdata/caps_2.6.0.x86_64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.7.0.s390x.replies | 28 +-
tests/qemucapabilitiesdata/caps_2.7.0.s390x.xml | 2 +-
.../qemucapabilitiesdata/caps_2.7.0.x86_64.replies | 22 +-
tests/qemucapabilitiesdata/caps_2.7.0.x86_64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.8.0.s390x.replies | 32 +-
tests/qemucapabilitiesdata/caps_2.8.0.s390x.xml | 2 +-
.../qemucapabilitiesdata/caps_2.8.0.x86_64.replies | 22 +-
tests/qemucapabilitiesdata/caps_2.8.0.x86_64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.9.0.ppc64.replies | 28 +-
tests/qemucapabilitiesdata/caps_2.9.0.ppc64.xml | 2 +-
.../qemucapabilitiesdata/caps_2.9.0.s390x.replies | 32 +-
tests/qemucapabilitiesdata/caps_2.9.0.s390x.xml | 2 +-
.../qemucapabilitiesdata/caps_2.9.0.x86_64.replies | 536 +++++++++---------
tests/qemucapabilitiesdata/caps_2.9.0.x86_64.xml | 2 +-
50 files changed, 1452 insertions(+), 1128 deletions(-)
--
2.16.1
6 years, 7 months
[libvirt] [PATCH 0/6] qemu: Add support for 'write-cache' disk frontend argument (blockdev-add saga)
by Peter Krempa
'write-cache' is one of the booleans the 'cache' attribute of -drive
translates to. Since we are getting rid of -drive this needs to be
implemented in a different way.
Peter Krempa (6):
tests: utils: Allow parsing test capability file without virCaps
tests: qemuxm2argv: Add infrastructure for testing with real qemuCaps
qemu: domain: Add helper for translating disk cachemode to qemu flags
qemu: caps: Add capability for 'write-cache' parameter of disk
frontends
qemu: Format 'write-cache' parameter for disk frontends
tests: qemuxml2argv: Test formatting of 'write-cache' parameter
src/qemu/qemu_capabilities.c | 5 ++
src/qemu/qemu_capabilities.h | 1 +
src/qemu/qemu_command.c | 27 ++++++++
src/qemu/qemu_domain.c | 75 ++++++++++++++++++++++
src/qemu/qemu_domain.h | 6 ++
tests/qemucapabilitiesdata/caps_2.10.0.aarch64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.10.0.ppc64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.10.0.s390x.xml | 1 +
tests/qemucapabilitiesdata/caps_2.10.0.x86_64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.11.0.s390x.xml | 1 +
tests/qemucapabilitiesdata/caps_2.12.0.aarch64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.12.0.ppc64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.12.0.s390x.xml | 1 +
tests/qemucapabilitiesdata/caps_2.12.0.x86_64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.7.0.s390x.xml | 1 +
tests/qemucapabilitiesdata/caps_2.7.0.x86_64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.8.0.s390x.xml | 1 +
tests/qemucapabilitiesdata/caps_2.8.0.x86_64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.9.0.ppc64.xml | 1 +
tests/qemucapabilitiesdata/caps_2.9.0.s390x.xml | 1 +
tests/qemucapabilitiesdata/caps_2.9.0.x86_64.xml | 1 +
tests/qemuxml2argvdata/disk-drive-write-cache.args | 45 +++++++++++++
tests/qemuxml2argvdata/disk-drive-write-cache.xml | 45 +++++++++++++
tests/qemuxml2argvtest.c | 32 +++++++++
tests/testutilsqemu.c | 21 ++++--
tests/testutilsqemu.h | 3 +
26 files changed, 270 insertions(+), 6 deletions(-)
create mode 100644 tests/qemuxml2argvdata/disk-drive-write-cache.args
create mode 100644 tests/qemuxml2argvdata/disk-drive-write-cache.xml
--
2.16.2
6 years, 7 months