[libvirt] [v0.9.12-maint v3 00/12] Debian's 0.9.12 patches
by Guido Günther
These are the patches Debian is currently carrying on 0.9.12. Most are
straight cherry-picks. Since we're maintaining 0.9.12 for our current
stable release I'm happy to push these to v0.9.12-maint.
The only change over v2 is the adjuste commit message.
Daniel P. Berrange (2):
Don't ignore return value of qemuProcessKill
Fix race condition when destroying guests
Eric Blake (1):
build: fix virnetlink on glibc 2.11
Jiri Denemark (3):
daemon: Fix crash in virTypedParameterArrayClear
Revert "rpc: Discard non-blocking calls only when necessary"
qemu: Add support for -no-user-config
Luca Tettamanti (1):
storage: Need to also VIR_FREE(reg)
Martin Kletzander (1):
security: Fix libvirtd crash possibility
Peter Krempa (4):
qemu: Fix off-by-one error while unescaping monitor strings
rpc: Fix crash on error paths of message dispatching
conf: Remove callback from stream when freeing entries in console hash
conf: Remove console stream callback only when freeing console helper
cfg.mk | 3 +-
daemon/remote.c | 16 +-
src/conf/virconsole.c | 13 ++
src/qemu/qemu_capabilities.c | 7 +-
src/qemu/qemu_capabilities.h | 1 +
src/qemu/qemu_command.c | 11 +-
src/qemu/qemu_driver.c | 21 ++-
src/qemu/qemu_monitor.c | 11 +-
src/rpc/virnetclient.c | 21 +--
src/rpc/virnetserverclient.c | 3 +
src/rpc/virnetserverprogram.c | 11 +-
src/storage/storage_backend_logical.c | 5 +-
src/util/virnetlink.h | 2 +
tests/qemuhelpdata/qemu-1.1 | 268 ++++++++++++++++++++++++++++++++++
tests/qemuhelpdata/qemu-1.1-device | 160 ++++++++++++++++++++
tests/qemuhelptest.c | 75 ++++++++++
16 files changed, 586 insertions(+), 42 deletions(-)
create mode 100644 tests/qemuhelpdata/qemu-1.1
create mode 100644 tests/qemuhelpdata/qemu-1.1-device
--
1.8.4.rc3
11 years, 2 months
[libvirt] [PATCH] docs: mention hostname subtlety
by Eric Blake
An off-list bug report mentioned some confusion where the public
documentation of libvirt.c:virConnectGetHostname did not match
the private documentation of util/virutil.c:virGetHostname.
* src/libvirt.c (virConnectGetHostname): Tweak docs.
Signed-off-by: Eric Blake <eblake(a)redhat.com>
---
src/libvirt.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/src/libvirt.c b/src/libvirt.c
index 20a2d4c..a6fcab0 100644
--- a/src/libvirt.c
+++ b/src/libvirt.c
@@ -1701,9 +1701,10 @@ error:
* virConnectGetHostname:
* @conn: pointer to a hypervisor connection
*
- * This returns the system hostname on which the hypervisor is
- * running (the result of the gethostname system call). If
- * we are connected to a remote system, then this returns the
+ * This returns a system hostname on which the hypervisor is
+ * running (based on the result of the gethostname system call, but
+ * possibly expanded to a fully-qualified domain name via getaddrinfo).
+ * If we are connected to a remote system, then this returns the
* hostname of the remote system.
*
* Returns the hostname which must be freed by the caller, or
--
1.8.3.1
11 years, 2 months
[libvirt] [PATCH] tools: add missing 'interface' type and update man page
by Alex Jia
Signed-off-by: Alex Jia <ajia(a)redhat.com>
---
tools/virt-xml-validate.in | 19 +++++++++++++++++++
1 files changed, 19 insertions(+), 0 deletions(-)
diff --git a/tools/virt-xml-validate.in b/tools/virt-xml-validate.in
index 6bfa68f..8be9595 100644
--- a/tools/virt-xml-validate.in
+++ b/tools/virt-xml-validate.in
@@ -83,6 +83,9 @@ if [ -z "$TYPE" ]; then
*secret*)
TYPE="secret"
;;
+ *interface*)
+ TYPE="interface"
+ ;;
*)
echo "$0: cannot determine schema type for $XMLFILE" >&2
exit 3
@@ -124,6 +127,10 @@ Valid schema names currently include
=over 4
+=item C<domainsnapshot>
+
+The schema for the XML format used by domain snapshot configuration
+
=item C<domain>
The schema for the XML format used by guest domains configuration
@@ -148,6 +155,18 @@ The schema for the XML format used by node device descriptions
The schema for the XML format used to declare driver capabilities
+=item C<nwfilter>
+
+The schema for the XML format used by network traffic filters
+
+=item C<secret>
+
+The schema for the XML format used by secrets descriptions
+
+=item C<interface>
+
+The schema for the XML format used by virtual interface
+
=back
=head1 OPTIONS
--
1.7.1
11 years, 2 months
[libvirt] [PATCHv2 0/4] Introduce APIs to extract DHCP leases info
by Nehal J Wani
This API returns the information stored in the DHCP leases file
created by dnsmasq for a given virtual network. It contacts the
bridge network driver, which parses the leases file.
It supports two methods:
1. Return info for all network interfaces connected to a given
virtual network
2. Return information for a particular network interface in a
given virtual network by providing its MAC Address
v2
* Since DHCPv6 is supposed to be suported in future, virNetworkGetDHCPLeasesForMAC
changed, prefix and virIPAddrType added in virNetworkDHCPLeases struct.
v1
* Refer: https://www.redhat.com/archives/libvir-list/2013-September/msg00620.html
* The need for these APIs were result of a RFC was proposed on the list.
Refer: http://www.redhat.com/archives/libvir-list/2013-July/msg01603.html
Nehal J Wani (4):
net-dhcp-leases: Implement the public APIs
net-dhcp-leases: Implement the remote protocol
net-dhcp-leases: Private implementation inside network driver
net-dhcp-leases: Add virsh support
daemon/remote.c | 133 +++++++++++++++++++++++++++++
include/libvirt/libvirt.h.in | 33 ++++++++
python/generator.py | 3 +
src/driver.h | 13 +++
src/libvirt.c | 173 ++++++++++++++++++++++++++++++++++++++
src/libvirt_private.syms | 1 +
src/libvirt_public.syms | 7 ++
src/network/bridge_driver.c | 193 +++++++++++++++++++++++++++++++++++++++++++
src/remote/remote_driver.c | 150 +++++++++++++++++++++++++++++++++
src/remote/remote_protocol.x | 50 ++++++++++-
src/remote_protocol-structs | 32 +++++++
src/rpc/gendispatch.pl | 1 +
tools/virsh-network.c | 101 ++++++++++++++++++++++
tools/virsh.pod | 6 ++
14 files changed, 895 insertions(+), 1 deletion(-)
--
1.7.11.7
11 years, 2 months
[libvirt] [RESEND][PATCHv5 0/4] write separate module for hostdev passthrough
by Chunyan Liu
[rebased to latest libvirt code for applying and reviewing the patches]
These patches implements a separate module for hostdev passthrough so that it
could be shared by different drivers and can maintain a global state of a host
device. Plus, add passthrough to libxl driver, and change qemu driver and lxc
driver to use hostdev common library instead of their own hostdev APIs.
---
Changes to v4:
* change the way checking hypervisor driver name to decide whether use pciback
or pci-stub as stub driver, instead, using driver callback to handle that.
* remove get active/inactive list APIs from hostdev common library since
currently no code uses them.
* add nodedev-detach/reattach/reset to libxl driver
* other fixes to Daniel and Jim's comments
v4 is here:
https://www.redhat.com/archives/libvir-list/2013-August/msg00806.html
Changes to v3:
* fix Jim's comments
v3 is here:
https://www.redhat.com/archives/libvir-list/2013-August/msg00019.html
Changes to v2:
* add patches for qemu driver and lxc driver, use common library APIs instead
of their own hostdev APIs.
* add APIs for nodedev-detach and nodedev-reattach calling.
* rename functions to use unified prefix 'virHostdev'
* use VIR_ONCE_GLOBAL_INIT() as others instead of previous Init and Cleanup.
* use VIR_STRDUP instead of strdup
* rebase to latest code
v2 is here:
https://www.redhat.com/archives/libvir-list/2013-June/msg00263.html
Chunyan Liu (4):
add hostdev passthrough common library
add pci passthrough to libxl driver
change qemu driver to use hostdev common library
change lxc driver to use hostdev common library
docs/schemas/domaincommon.rng | 1 +
po/POTFILES.in | 3 +-
src/Makefile.am | 3 +-
src/conf/domain_conf.c | 3 +-
src/conf/domain_conf.h | 1 +
src/libvirt_private.syms | 15 +
src/libxl/libxl_conf.c | 63 ++
src/libxl/libxl_conf.h | 4 +
src/libxl/libxl_domain.c | 9 +
src/libxl/libxl_driver.c | 443 ++++++++++++++-
src/lxc/lxc_conf.h | 4 -
src/lxc/lxc_driver.c | 45 +-
src/lxc/lxc_hostdev.c | 413 -------------
src/lxc/lxc_hostdev.h | 43 --
src/lxc/lxc_process.c | 21 +-
src/qemu/qemu_command.c | 1 -
src/qemu/qemu_conf.h | 9 +-
src/qemu/qemu_domain.c | 9 +
src/qemu/qemu_driver.c | 72 +--
src/qemu/qemu_hostdev.c | 1289 ---------------------------------------
src/qemu/qemu_hostdev.h | 72 ---
src/qemu/qemu_hotplug.c | 126 ++---
src/qemu/qemu_process.c | 34 +-
src/util/virhostdev.c | 1335 +++++++++++++++++++++++++++++++++++++++++
src/util/virhostdev.h | 104 ++++
src/util/virpci.c | 28 +-
src/util/virpci.h | 9 +-
src/util/virscsi.c | 26 +-
src/util/virscsi.h | 8 +-
src/util/virusb.c | 27 +-
src/util/virusb.h | 8 +-
31 files changed, 2195 insertions(+), 2033 deletions(-)
delete mode 100644 src/lxc/lxc_hostdev.c
delete mode 100644 src/lxc/lxc_hostdev.h
delete mode 100644 src/qemu/qemu_hostdev.c
delete mode 100644 src/qemu/qemu_hostdev.h
create mode 100644 src/util/virhostdev.c
create mode 100644 src/util/virhostdev.h
11 years, 2 months
[libvirt] [PATCH] tools: fix a judgment of equalling zero about an array's length
by lawrancejing
There is no need to go on executing code when the array's length is zero.
---
tools/virsh-snapshot.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/tools/virsh-snapshot.c b/tools/virsh-snapshot.c
index e37a5b3..d7a4c7b 100644
--- a/tools/virsh-snapshot.c
+++ b/tools/virsh-snapshot.c
@@ -239,7 +239,7 @@ vshParseSnapshotMemspec(vshControl *ctl, virBufferPtr buf, const char *str)
return 0;
narray = vshStringToArray(str, &array);
- if (narray < 0)
+ if (narray <= 0)
goto cleanup;
for (i = 0; i < narray; i++) {
--
1.7.1
11 years, 2 months