
27 Nov
2007
27 Nov
'07
3:44 p.m.
HE> + if (info->assoc_class) { HE> + pfx = class_prefix_name(info->assoc_class); HE> + HE> + if (!STREQC(ref_pfx, pfx)) { HE> + if (!STREQC("CIM", pfx)) I would rather this be: if (!STREQC(ref_pfx, pfx) && !STREQC("CIM", pfx)) rc = false; It cuts down on the nesting and makes the true condition clearer, I think. Also, could we name this function a little better to avoid confusion with the ASSOC_MATCH macro? ASSOC_MATCH should probably be named ASSOC_MATCH_PN, but it would be easier to make the name of this new function more explicit. Thanks! -- Dan Smith IBM Linux Technology Center Open Hypervisor Team email: danms@us.ibm.com