+
+static CMPIStatus sapavail_to_host(const CMPIObjectPath *ref,
+ struct std_assoc_info *info,
+ struct inst_list *list)
I missed this last time around.. usually we use the term "host" to refer
to the physical system. Since this is matching a KVMRedirectionSap
reference to a guest or domain, I'd call this something like
sapavail_to_guest() or sapavail_to_dom()
+
+
+static CMPIStatus host_to_sapavail(const CMPIObjectPath *ref,
+ struct std_assoc_info *info,
+ struct inst_list *list)
Same here - change host to guest, dom, domain, etc.
+
+ if (STREQC(dom_host_name, sap_host_name))
+ inst_list_add(list, temp_list.list[i]);
+ }
+
+ out:
+ if (temp_list.list != NULL)
No need for this check here.
+ inst_list_free(&temp_list);
--
Kaitlin Rupert
IBM Linux Technology Center
kaitlin(a)linux.vnet.ibm.com