KR> +static struct std_assoc rasd_to_rasd = {
KR> + .source_class = "CIM_ResourceAllocationSettingData",
KR> + .source_prop = "ManagedElement",
KR> +
KR> + .target_class = "CIM_ManagedElement",
KR> + .target_prop = "SettingData",
KR> +
KR> + .assoc_class = "CIM_ElementSettingData",
KR> +
KR> + .handler = rasd_to_sd,
KR> + .make_ref = make_ref
KR> +};
A relatively minor comment, but this block confused me at first, since
your function is rasd_to_sd, but your block is rasd_to_rasd. Perhaps
a better name could make it more clear? I think tacking on a leading
'_' to disambiguate the std_assoc block from the handler function is a
reasonable way to do this (and how I've done it in the past, IIRC).
--
Dan Smith
IBM Linux Technology Center
Open Hypervisor Team
email: danms(a)us.ibm.com