Heidi Eckhart wrote:
# HG changeset patch
# User Heidi Eckhart <heidieck(a)linux.vnet.ibm.com>
# Date 1201177348 -3600
# Node ID 4cbd5d50bee23b8cf6d08f5724aef04b011d2030
# Parent 70dedb925282ed3ceccf95872537204a1531c777
HostSystem: check if input ref is valid
Signed-off-by: Heidi Eckhart <heidieck(a)linux.vnet.ibm.com>
diff -r 70dedb925282 -r 4cbd5d50bee2 src/Virt_HostSystem.c
--- a/src/Virt_HostSystem.c Thu Jan 24 12:56:45 2008 +0100
+++ b/src/Virt_HostSystem.c Thu Jan 24 13:22:28 2008 +0100
@@ -112,19 +112,35 @@ CMPIStatus get_host_cs(const CMPIBroker
static CMPIStatus return_host_cs(const CMPIObjectPath *reference,
const CMPIResult *results,
- int name_only)
+ int name_only,
+ bool getInstance)
A bit nitpicky here, but I think here name_only is an int that's being
use as a boolean, while getInstance is an actual boolean. I'm fine with
doing things either way, but for the sake of consistency they should
probably be the same. I'd vote for making name_only a bool.
--
-Jay