On Sat, Jul 18, 2026 at 14:57:54 +0200, Roman Bogorodskiy wrote:
Move:
* qemuAgentDiskInfoFormatParams * qemuAgentFSInfoFormatParams * virDomainInterfaceFormatParams
from the qemu driver to hypervisor/qemu_agent.c so they could be reused by the other drivers implementing virDomainGetGuestInfo() using the qemu agent.
Also, rename virDomainInterfaceFormatParams() to qemuAgentInterfaceFormatParams() to follow the common naming schema as it's not really used outside of the qemu agent related code.
Signed-off-by: Roman Bogorodskiy <bogorodskiy@gmail.com> --- src/hypervisor/qemu_agent.c | 159 +++++++++++++++++++++++++++++++++++ src/hypervisor/qemu_agent.h | 17 ++++ src/libvirt_private.syms | 3 + src/qemu/qemu_driver.c | 162 +----------------------------------- 4 files changed, 180 insertions(+), 161 deletions(-)
diff --git a/src/hypervisor/qemu_agent.c b/src/hypervisor/qemu_agent.c index e549947fbf..36134e3cc2 100644 --- a/src/hypervisor/qemu_agent.c +++ b/src/hypervisor/qemu_agent.c @@ -2681,3 +2681,162 @@ qemuAgentFSInfoFormat(qemuAgentFSInfo **agentinfo, } return ret; } + +void
Preferrably use 2 newlines between functions. Reviewed-by: Peter Krempa <pkrempa@redhat.com>