+ } else if (type == CIM_RES_TYPE_DISK) {
+ *s = enum_pools(broker, reference, type, &list);
+ if (s->rc == CMPI_RC_OK)
+ inst = list.list[0];
+ } else if (type == CIM_RES_TYPE_NET) {
+ *s = enum_pools(broker, reference, type, &list);
+ if (s->rc == CMPI_RC_OK)
+ inst = list.list[0];
I somehow missed this last time - you could collapse these statements
into one else if. However, I think having the statements parallel the
PROC and MEM statements is easier to read (and easier to change later on
if need be).
+1
--
Kaitlin Rupert
IBM Linux Technology Center
kaitlin(a)linux.vnet.ibm.com